Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Log In

A valid email is required.
Password is required.
Posted: 3/20/2017 4:16:56 PM EDT
Hi guys,
I could really use some advice from one of the NVG gurus on here if at all possible.

I have a Canadian built PVS-14 with a Russian gen 3 katod tube. So far I've been very happy with the unit and it is a solid performer.

But I'm becoming concerned about something I've come across in online forums called "slow start up".

Since day 1 (bought the unit new from the mfgr) the tube has always taken a bit of time to "warm up" after being left off for ~10 minutes or more. When this happens the image in the tube slowly brightens over the course of approx 3 seconds once the unit is switched on. Switching it on with less time in between being off results in a fully bright image in about 1 second.

This wasn't a concern to me for a long time because it was like that from day 1, its consistent, and it hasn't gotten any worse in the time I've used the tube. The tube performs perfectly otherwise, no flickering, no blems, no shading, autogating and abc work properly. I've only got about 60 hours of actual use on the tube. I've used CR123s and AAs and the unit functions the exact same regardless of which battery is in it.

However I've seen talk of tubes with "slow start up" that sounds eerily close to what I'm experiencing. And those references are usually followed up by scary phrases like "bad psu" or "going to air".

Is there a benign reason my tube could be like this? The company that builds the housing states they use a proprietary electronics board that "performs reliable start up current for "sleepy" image intensifier tubes"...

If it does mean it's definitely a bad psu, how long until the tube breaks? What other symptoms can/will occur? The tube came with a generous 7 year warranty but I may not always be in a position to make use of said warranty and if the tube is doomed to fail I would like to know sooner rather than later. Are there any further things I can check for?

Would really appreciate any and all feedback
Link Posted: 3/20/2017 6:11:22 PM EDT
why would you buy a katod tube when Canada can buy export Gen 3 from USA without problem.

It does not sound good to be honest your tube is slow start up. Id sell it off and buy a proper pvs14 with a gen 3 usa as the glass is better and so is the tube
Link Posted: 3/20/2017 6:14:22 PM EDT
We definitely cannot buy export US gen 3 here in Canada. There is a gray market for US gen 3 units, but you are buying from people with no guarantee of what you are getting, no warranty, and zero recourse if anything goes wrong.
Link Posted: 3/20/2017 6:24:32 PM EDT
Link Posted: 3/20/2017 7:50:49 PM EDT
If there is a warranty id use it sooner rather than later. Russian PS's arent always the best.
Link Posted: 3/20/2017 8:31:12 PM EDT
[Last Edit: 3/20/2017 8:32:04 PM EDT by murtis]
Discussion ForumsJump to Quoted PostQuote History
Originally Posted By TNVC_Sam:
The Classification for gen 3 is determined by the US
View Quote
Maybe 3 ????????? ??? then?

Edit: well that didn't go exactly to plan. Just imagine some cryptic alphabet instead.
Link Posted: 3/21/2017 3:56:44 AM EDT
Katod makes quite a few different gen 3 tubes (GaAs photocathode), if you bought from a reputable dealer i`m sure it is gen 3. They make direct replacement ANVIS and PVS-14 type tubes with autogated power supplies with decent specs (27 sn & 2000 pcr) I dont know about the slow start up issue,(could be a problem with the buck boost voltage doubler chip on the power supply board in the battery housing) but with a 7 yr warranty you should be ok.
Top Top