Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 2/8/2006 3:18:05 PM EDT
Having owned three Kimbers, I have noticed that the cartridges seem to make contact with the slide stop, leaving a copper colored mark. This results in the slide occassionally locking back prematurely. Looking at new Kimbers, which have presumably been test fired, they seem to all have the copper mark on the slide stop as well. MIM parts have excellent tolerances, so it's not like they're out of spec. I'm curious, is this behavior normal?
Link Posted: 2/8/2006 3:36:12 PM EDT
Maybe the first bullet in your magazine when you load might touch it but I other than that, there is no possible way the cartridge/bullet/ammo can touch the slide stop. I could be wrong.

Do you have factory magazines?
Link Posted: 2/8/2006 3:56:05 PM EDT
CMC Power Mags and Wilson 47Ds.

But suppose the rounds are hitting the slide stop, what would be the appropriate fix? File it down? Detent the slide stop?
Link Posted: 2/9/2006 6:44:37 AM EDT
Yes. That is the reason why SSs have the detent.
Link Posted: 2/9/2006 4:53:44 PM EDT
My latest Kimber, a TLE/RL, locked back prematurely 7 times in the first 500 rounds. I took the gun to a shop to have the slide stop modified. I thought they were going to file down the area being hit, but instead they detented the rear. Fired 250 rounds today with no malfunctions. Will continue to test fire it over the next week, but so far, it seems as though the issue has been resolved. I have a class next weekend, and I really want to shoot a 1911, so things are looking up.
Link Posted: 2/10/2006 11:45:27 AM EDT
What do you mean by "detent the slide stop"? Make a small dimple on the slide stop to catch a little better? My RIA does exactly the same thing, mostly with HP ammo though.
Top Top