Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 12/27/2005 9:42:56 AM EDT
thought maybe someone here might be able to help me, my sar-1 is getting light primer strikes every now and then, seems like it is more often when i bump fire it, actually didnt start doing it until i started bump firing. but it still does it about once a mag full shooting single fires. the rounds will fire if you eject them, load them in the mag and recharge the bolt. is it a firing pin problem? oh yea, its not the ammo. a buddy is shooting the same ammo- wolf and silver bear. he has no problems like this.



thanks tim
Link Posted: 12/27/2005 1:33:00 PM EDT
Check that the firing pin is a free floating fit in the bolt.
If there is some grit or sludge in there the firing pin won't hit the primer well enough.
Dribble some break free or other good solvent in the backside and work the pin back & forth. You can flush it like that and even blow compressed air in the front side to blow stuff to the rear. Once it's moving freely put a drop of lube in there and try it again.
Link Posted: 12/27/2005 2:08:45 PM EDT
Stock trigger group, no work done on it? I had a trigger group that had been polished that started to do the same. Except mine was shooting 2 or 3 at a time while trying to do slow fire, followed by light hits. Finally just traded it out for a G2.
Link Posted: 12/27/2005 2:25:55 PM EDT
yea, its the stock trigger, been thinking about a G-2 or (red star )? just havent done it yet. doesnt really seem like a trigger problem though. any other thoughts or suggestions?
Link Posted: 12/27/2005 2:33:18 PM EDT
May also want to look in the receiver, make sure there's nothing extra floating around in there.
Top Top