Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/29/2005 11:59:53 AM EDT
Well, went out to a shoot today with some fellow Ohio ARCOM members, and got to break in the new rifle. When I went to insert the mag, I had to literally force it in. The mag was from K-Var (circle 21), and when I tried the mag the rifle shipped with, it was very snug, but not to the point where I was forcing it. I ran one or two mags through the rifle and then started getting stoppages about every 5-6 rounds. It was not ejecting the spent round, and the spent round was actually getting jammed between the left side of the cover and the round being chambered. In some cases the spent casing was actually going into the rear of the receiver. I have no idea what was going on, but it was occuring with Wolf FMJ and Barnaul SP (which had additional misfeed problems).

On the positive side, I was nailing the metal targets with regularity, so it's an accurate rifle.

Anyways, I'm going contact Arsenal regarding an RMA to get it fixed, but has anyone else had these kinds of problems with the SLR-105's or other AK's in general? I've had 4 7.62 AK's and have never had anything like this happen.
Link Posted: 10/29/2005 12:36:42 PM EDT
Link Posted: 10/29/2005 12:40:58 PM EDT
You ever just get the feeling someone or something is out to get you???
Link Posted: 10/29/2005 12:43:22 PM EDT
Link Posted: 10/29/2005 5:32:44 PM EDT
Boy, that sucks. I too have taken out my cherry SLR105A1R and luckily didn't have any problems. Shot Wolf, Silver Bear, and Ulyanovsk brand ammo. Sighted in a w/ PK AS, and it's extremely accurate. 1 1/2 - 2" groups at 100 yds.

My rifle came with a brown circle 21 mag that was snug. I purchased a lot of circle 10 mags, some were snug and some had a little play. In comparing the two mags......the 10s look like they were sanded on the bottom rear corners and top rear corners. I personally like a snug mag. That said, the 10s worked fine though.

Let us know what ARSENAL says.
Link Posted: 10/30/2005 4:26:32 AM EDT
I bought some mags for mine that wouldn't even go all the way in until I filed a little of the plastic off at the top rear of the mag. Mag was hitting the crosspin but now all fit nice and tight. Sorry about the FTE's. That's always a major bummer with any rifle, let alone a brand new one.

MBR
Link Posted: 10/30/2005 3:28:52 PM EDT
I was able to jam mine by force feeding it Wolf HP but besides that she works just fine

Link Posted: 10/30/2005 3:44:46 PM EDT
[Last Edit: 10/30/2005 3:46:40 PM EDT by Lxpony]
same rifle being shot by a co-worker friend of mine..... The finish sucks and I get trigger slap but it looks like a million bucks!!

Link Posted: 11/3/2005 5:06:02 PM EDT
Well I'm taking the day off work tomorrow and taking the SLR and my muzzleloader up to the range. I cleaned the SLR up tonight and noticed that the rifle is just incredibly hard to cycle when the trigger has been pulled. It also gets a bit hung up at the rear of the cycle. I checked out the hammer and it has a spur on the back of it, and I compared it to my Norinco and the bottom of the bolt and the hammer on the 56S-1 are both smooth, while the SLR is not, and seems to bind up. The hammer spring also slipped off the one side of the trigger, and when it did it compressed the hammer all the way down. I didn't notice this when it happened, but the action was as smooth as butter (until I figured out the hammer wasn't up and the trigger wouldn't work). So I'm going to take it out tomorrow and run some more Wolf through it and see where we stand.

I did talk to Arsenal, although I was never able to get ahold of John. They said to send the rifle back and they'd take a look at it, but I'm thinking I may try to fix it by polishing the bottom of the bolt and the hammer and reducing the binding. I'll have to talk to them first though because of course I wouldn't want to void my warranty.

Has anyone else ever run into this with the hammer and such? The action is so stiff I'm wondering if that's not having some impact on the cycling, and the ejection of the spent casings.
Link Posted: 11/5/2005 3:56:43 PM EDT
Well, I went out yesterday to see if a good cleaning and attention to the hammer, bolt, and rails might fix the problem. Cleaned everything up with CLP and a toothbrush and, wiped it all down, and lubed it up again. I shot 3 20 round mags though it, increasing the rate of fire, with no problems. I set the SLR down and shot my muzzleloader a little, then loaded up 2 more mags of 20 and tried again. This time I got off like 3 rounds before I got a jam, then a couple and a jam, and so on. On that 1 mag I had 4 jams out of 12 rounds fired. I finally just left a jammed round in it and unloaded the mag. All 4 that jammed jammed up just like this one, and this is what it was doing last weekend as well.

I'm going to ship it back to Arsenal for repairs just as it is, with the spent cartridge jammed up in it, so they can see exactly what it's doing.

I also included a couple pics at the end of this of a pin in the front sight block. First off, it's silver, so I don't know whether it's supposed to be parked/coated, but if you look it's not flush, and the other side looks about half assed punched. I'm only asking for comments here, as I've never had an AK-74 clone, but it looks to me like they popped the FSB off and half assed this one on. Just wondering if I should mention this as something they need to repair.











Link Posted: 11/5/2005 6:04:37 PM EDT
that rivet on the FSB is supposed to be nickel colored but it isnt supposed to be smashed like that on the back side...........
Link Posted: 11/5/2005 7:16:44 PM EDT
Link Posted: 11/6/2005 4:17:24 PM EDT
Amazing quality control (or lack of it)!

Very disaaponiting.
Link Posted: 11/24/2005 8:59:27 AM EDT
Sorry to hear about your luck. You don't have too many rnds through your rifle so I'd bet it just needs some break-in time...but if you're not happy with it send it back. It was hard to pull back the bolt on my SLR before I got mine lubed up. Then it worked fine. The mag that came with it fit perfect, but felt tight to me since I was used to the WASR I had. Arsenal should take care of you! Don't be discouraged... the AK-74 has become my favorite rifle.
Link Posted: 11/24/2005 2:24:12 PM EDT
[Last Edit: 11/24/2005 2:24:54 PM EDT by Fallschirmjager]
Rifle has already been shipped and repaired by Arsenal, now I'm just waiting for them to send it back to me (should be going out Monday).

So far as breaking in, a failure to eject shouldn't be a "breaking in" issue. A less than smooth action is a breaking in issue. I've had 3 other Arsenals and have a Norinco (all new) as well and never had this issue, but again, they have stated it was repaired so lets see how it works out.
Link Posted: 12/9/2005 7:35:01 AM EDT
I received the rifle back Tuesday and Arsenal included a note stating the FSB and pin was replaced. Of course that has nothing to do with why it was jamming, so I called them up and asked for an explanation of the repairs. Although they didn't document it, I was told they replaced the bolt head assembly, which I figured they might have done since it looked new, and they didn't tell me this but it's got a new hammer in it as well.

I'll include a range report as soon as I can get out (indoor range doesn't allow any ammo with any steel components, and outdoor range is closed for repairs), but I thought I'd post this just to show Arsenal actually had a pretty damn great turnaround time on this repair (2 weeks to the day, including shipping).
Link Posted: 12/9/2005 12:04:02 PM EDT
Link Posted: 12/10/2005 1:31:33 AM EDT
Keep us informed and I wish I had a "Shooting Buddy" like yours!
Link Posted: 12/14/2005 7:16:47 AM EDT
Tag
Link Posted: 1/7/2006 6:13:59 PM EDT
Finally got out to the range today and did a function fire (appropriate as there are no target backers left on the range now). I burned through 110 rounds, in 4 mags of 20 and a 30 rounder, and switched between shot slow aimed, rapid, and bump firing. Rifle was a champ, no issues, and actually surprised me as it was unbelievably controllable during bump firing. I generally don't bump fire as I consider it a waste of ammo, but as this was a function fire, I figured I'd let a few off. I was surprised how well it fired and stayed right there.

Anyways, all seems well. I'll add more later, as the wife is yelling at me to go back to watching this damn movie...
Link Posted: 1/7/2006 6:28:12 PM EDT
Top Top