Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 4/13/2003 11:47:01 AM EDT
[Last Edit: 4/13/2003 11:48:10 AM EDT by Derek45]
My new SAR-3 with my new RSA trigger kit for the SAR-3 is locking up under radid fire.

When I'm shooting, sometimes the weapon jams, the bolt gets caught by the hammer. The bolt is to the rear of the weapon, the hammer is holding it back. The only way to restore it is to pull off the dust cover and stick a screwdriver into it, cocking the hammer again so the bolt can move forward again.

Pulling the carrier further to the rear doesn't unlock it.

Anybody else having this trouble?
Thanks
Link Posted: 4/13/2003 1:05:38 PM EDT
Link Posted: 4/13/2003 1:18:27 PM EDT
Now that's standin' by your product!

I haven't dealt with you gents yet but I'm lookin' forward to the day.
Link Posted: 4/13/2003 5:19:08 PM EDT
Link Posted: 4/16/2003 6:00:59 PM EDT
[Last Edit: 4/16/2003 6:04:49 PM EDT by Derek45]
I thought it was the disconnector too.
It wasn't, I adjusted it at the range.

Ken, thanks for the reply, great service, I tried to call you Yesterday late afternoon.
Randal Power called me back today.

He thought the top of the hammer needed to be trimmed/ radiused / polished. ( not the hook, the area just above where the back of the bolt makes contact)He thought the holes in the revceiver might have been drilled too high at the factory.
I just got done trimming it, polishing it, I'll test fire it in the near future.
Link Posted: 4/16/2003 6:19:43 PM EDT
Link Posted: 6/1/2003 1:28:56 PM EDT
[Last Edit: 6/10/2003 5:21:02 PM EDT by Derek45]
Well,...
radiusing the hammer solved the first problem, now I'm having a problem with the disconnector not releasing. I've tried adjusting it back and forth.
Here's what happens:
pull trigger
weapon fires and cycles.
when I release the trigger the disconnector should release the hammer and the sear should hold it back until the trigger is pulled again. "click".

That's not happening, when I release the trigger, the disconnector continues to hold the hammer back, until I reach into the weapon and gently move the disconnector back, then I hear the normal "click" and the weapon will fire again.
With the dust cover off I can fire the rifle, but I have to reach inside and give the disconnector a little shove to release it.

I have it set up for a single stage pull. If I loosen up the take-up and overtravel screws, it runs better, but having a crisp single action trigger is why I spent the $70 !

I tried very slightly polishing the two surfaces and even with tetra or FP-10 oil, it the disconnector still snags on the hammer.

In desperation, I put the stock trigger and disconnector back in, and used only the RSA hammer. I know the stock hammer has poor geometry. Now the gun will fire in short bursts until it hammer follows and I end up with hammer down on a live round.

Now I'm getting so aggravated, I'm thinking about selling the gun.

Link Posted: 6/1/2003 1:49:21 PM EDT
Sounds like you've come full circle back to a disconnector problem which was likely your problem in the first place.

Send it to Ken. What've you got to lose?

Just a little aggravation and some insomnia
Link Posted: 6/1/2003 7:15:35 PM EDT
I installed the RSA trigger group in my gun after my finger started turning blue from trigger slap. This is a tip to all who plan on purchasing the RSA trigger group in the future. DONT MESS WITH IT WHEN YOU GET IT! I tried monkeying with the trigger group when I got it too, after hours(at least 2) of adjusting and readjusting I think I have finally gotten it to fire the way I want it. With just a little trigger pull before it unleashes that sweet sound.

If you are still having problems with your trigger and you really dont want to send it out my advice would be to reset the threads to factory setting as shown on the piece of paper that comes with the trigger group. Then go from there, adjusting each thread until you find the setting that works in the rifle as well as to your liking.
Link Posted: 6/1/2003 8:38:40 PM EDT
I posted some trigger set instructions from Campybob you guys might find useful.
Link Posted: 6/9/2003 6:36:34 PM EDT
I sent the rifle to RSA today.

Ken,
Thanks Again

Link Posted: 6/10/2003 3:46:55 PM EDT
You do know there were two adjustments on the disconnector??
Link Posted: 6/10/2003 5:12:59 PM EDT

Originally Posted By HeavyMetal:
You do know there were two adjustments on the disconnector??



Is a ducks ass water-tight?
Link Posted: 6/20/2003 2:20:28 PM EDT
I got the rifle back last night.
it looks like they polished the trigger pin, and possibly changed out the disconnector.
??
I'm not sure what they did, no note was enclosed.

I asked for a single stage trigger, it came back feeling like a tuned M14 trigger.

When I was playing around with it and having trouble, I had it set with very little take-up or overtravel. Maybe that was My problem.
I had it set up the way I do a 1911 trigger.

I took it to the club today and ran about 90 rounds thru it without any trouble.

I don't plan on adjusting it. It runs, and I'm happy.

Thanks Red Star Arms for your excellent service.


Link Posted: 6/20/2003 3:18:03 PM EDT
Derek, Glad everything turned out. RSA is the best. Where do you go to shoot. I see you are near St Louis. I work in St Louis and live west about 90miles. CB
Link Posted: 6/20/2003 7:27:50 PM EDT
[Last Edit: 6/20/2003 7:28:47 PM EDT by Derek45]

Originally Posted By cb69:
Derek, Glad everything turned out. RSA is the best. Where do you go to shoot. I see you are near St Louis. I work in St Louis and live west about 90miles. CB



I shoot at the Arnold, MO gunclub.
It's south of St.Louis, on I-55, exit 185
Link Posted: 6/20/2003 8:10:37 PM EDT

Originally Posted By Econfina:
Now that's standin' by your product!

I haven't dealt with you gents yet but I'm lookin' forward to the day.



Well, should I ever get the AK bug, I sure-as-shit know which company I will be doing business with!
Link Posted: 6/20/2003 8:46:53 PM EDT
I can verify everything that's been said about Red Star Arms on this thread. These people are absolutely top notch. I sent my VEPR there to have them install the trigger and not only did they follow my desires (very short first stage, short second stage, 4.5-5 pound pull) but they did the work much faster than I had expected. I had the weapon back within a week!

Fantastic customer support. Great product. I wish every gun parts supplier/manufacturer was as super as they are.

Mike Sigman
MBSigman@aol.com
Top Top