Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 2/5/2006 11:47:36 AM EDT
[Last Edit: 2/5/2006 11:48:02 AM EDT by rcav8r]
This is my first build...definitely made a few mistakes on this one, like mislocated holes. I welded those up and redrilled. One of the lower rails popped off (crummy mig weld, had to redo it), and it looks pretty rough. I didn't even bother to paint it. I figure I'll be rebuilding it in the future.

Anyways, the bolt carrier still sticks a bit in the rearward position, making it a single shot. It needed a nudge to pick up the next round and go forward. Need to take a bit more off the rails, looks like.

Definitely has potential! :)

as soon as I take care of this one, its on to the other romy and the polish underfolder.
Link Posted: 2/5/2006 12:35:07 PM EDT
[Last Edit: 2/5/2006 12:35:24 PM EDT by TheRedHorseman]
best thing to do I've found is to take a few files and a magic marker with me the first time I shoot a build. marker the hell out of the upper and lower rails, then you can see if it is binding anywhere by looking for where the marker is rubbed off. just adjust as needed

anyway congrats on the new build
Link Posted: 2/5/2006 4:01:40 PM EDT
Actually, after cleaning the gun and checking over carefully, it doesn't appear to be the rails after all.

It looks like the bolt carrier, at the bottom front of the bolt housing, is dragging hard on the corner of the new hammer.

In just about any other position, there is enough spring force to close the bolt, but the wolf I was shooting was kicking it just this far back so that it hung up on the hammer.

It looks like I'll have to take the hammer out and grid a little bit off. Maybe some off the bolt carrier too, or at least make it a smoother transition.

John
Top Top