Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/22/2003 10:33:31 PM EDT
I have a new Bushmaster with a 20" heavy barrel. If I load the magazine with the bolt closed, then pull back the charging handle to load a round, it fails to load. If I load the magazine with the bolt open, a round chambers just fine. I have had no other issues or failures to feed.

Any help would be appreciated--hopefully there is not a thread about this already.
Link Posted: 10/23/2003 12:13:39 AM EDT
Are the rounds feeding low when they FtF?
Link Posted: 10/23/2003 6:20:29 AM EDT
Are you rideing the chargeing handle? If you are that will happen. Just pull it back and let it fly. 556Cliff
Link Posted: 10/23/2003 6:34:57 AM EDT
Open the ejection port cover. Load a magazine into the rifle. Watch the bullets in the magazine through the ejection port as you pull the charging handle back slowly. The bolt should knock them down somewhat when pulled back, but the rounds should pop right back up into place once the bolt/bolt carrier has cleared them. Particularly watch the rear of the rounds to make sure they are not getting stuck-down in the rear of the magazine. If all looks fine, let the charging handle fly forward. If a round loads, then maybe you had your magazine loaded to a different level (+/- rounds) the last time. If it still doesn't load, then atleast you will know it's not the magazine.
Link Posted: 10/23/2003 9:39:39 AM EDT
OK I feel like a dummy. I looked throught ejection port while I pulled back the charging handle and the bolt did not move the rounds at all. When I loaded a magazine with the bolt closed I just tapped on the mag, but not hard enough. I was not even seating the mag.[thinking] Tried again and hit it pretty hard, magazine locked in and chambered a round just fine. Thanks for the replies.
Top Top