Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 8/20/2003 6:54:07 AM EDT
Just received an assembled Mega Lower and it failed a function check. When I slowly release the trigger the hammer will fall, if I release it quickley it dosn't fall. What should I look for that could cause this? Would it be easier to order and install a RRA trigger setup?
The Lower is a nice one, matches the 16" dpms slick sided upper very nicely!

Greg
Link Posted: 8/20/2003 4:23:02 PM EDT
Greg_in_Oscoda, It sounds like you need slighly more disconnector engagement. If you bought the lower assembled send it back. Messing with this part of the rifle could get expensive if you have no experience. If you want to continue to DIY then let us know. Thank you for an articulate, concise, and informative post. Pretty dam good for 1 of 1. Others should take heed.
Link Posted: 8/21/2003 4:14:02 AM EDT
Seems it would be much easier to try a fix here than sending it back. I'm at the shop right now and left the lower at home and will take a peek at the disconnector tonight. Greg
Link Posted: 8/21/2003 8:37:12 AM EDT
First thing to check: With the hammer forward, cock the hammer by hand. Look at the tip of the hook on the disconnector and the middle hammer hook on the hammer. As you push down on the hammer those two parts should look like they are almost going to touch, almost but not quite. If there is a discernable gap between the two hooks then the disconnector probably needs work.
Link Posted: 8/22/2003 4:39:44 AM EDT
[Last Edit: 8/22/2003 6:13:15 AM EDT by Greg_in_Oscoda]
Ok, Tried doing this with both the trigger back and released. With the trigger held back the disconnector solidly connects and holds the hammer. With the trigger released it has a large gap when the hammer is moved by hand. It appears that the fcg functions well when the trigger is released quickly, the hammer catches on the sear and dosn't fall after being released by the disconnector. it's only when released slowly that it appears the sear isn't catching? The disconnector seems to function so the hammer dosn't follow the bolt forward but the hammer falls when going slow. There is a small light drag and click after the disconnector releases the hammer. (sear not engaging enough?)
Link Posted: 8/22/2003 6:09:46 AM EDT
Just ordered the rra 2 stage from GPSS. I'd still like to figure this problem out and use it as an education. I've done trigger work on mini-14's and ruger bolts so I am familiar with most aspects but this one has me baffled a bit. I appreciate the help and guidance. Greg
Link Posted: 8/23/2003 9:39:45 PM EDT
[Last Edit: 5/25/2004 9:48:37 AM EDT by Tweak]

Originally Posted By Greg_in_Oscoda:
There is a small light drag and click after the disconnector releases the hammer. (sear not engaging enough?)




Greg,

Are you saying that the hammer drags when the disco releases it?
Link Posted: 8/23/2003 10:37:39 PM EDT
This sounds like a classic example of a bad trigger job on an ar15. You should have always have enough sear engagement to operate safely. So even if you release the trigger very, very slow, the hammer should engage the sear when the disconnector disengages. BTW ,From time when the disconnector releases, to when the hammer engages the sear, the hammer will drop a very short distance. Stuart
Link Posted: 8/25/2003 2:03:14 AM EDT
I removed all of the fcg and jigged it up in a jig I fabricated and found that the drop off the disconnector is a lot...the trigger has very rough spots and needs to be replaced.Just not very good quality unlike the lower. The lower is excellent but the fcg leaves a lot to be desired so it will be replaced with a rra group. Tweak, no it dosn't drag it just drops (hammer) far too much when the disconnector disengages due to tolerances not being up to a quality fcg. Greg
Link Posted: 8/26/2003 7:10:21 AM EDT
Ok, if the hammer was dragging you had other problems. Hold the trigger to the rear, fully cock the hammer by hand and release the trigger. Push down on the hammer slightly. Do you hear a click? The solution to lack of disco engagement (the gap between the middle hammer hook and the tip of the disco) ,given that is the actual problem and the lower and FCG parts are correct, is to remove material from under the "nose" of the disco. This is the front area where the disco sits/stops on the trigger. Remove a slight bit (coupla .001s) then reassemble and check. Be aware that by doing this you are rotating the disco about the trigger pin and causing the rear of the disco to sit up higher. That will lead to hammer strikes on the rear of the disco which can also lead to intermittent doubling.
Top Top