Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 11/4/2003 4:38:54 PM EDT
I have some Royal Ordnance SA80 mags from ammoman, one of which has too narrow a body (rounds touch on both ends and causes jams) and I am sending it back. The rest are great, except that one doesn't seem to work quite right with the LULA I have. Three of them work just fine, rotate the lever, drop one in, rotate the lever, drop one in. The one that doesn't work requires me to wiggle the LULA to get the round to sit properly before I can rotate the lever and push it into the mag. It seems to shoot okay, but I have only shot one mag through each mag (had to use a buddy's gun and he didn't have enough ammo) and it didn't have a problem at the range.

Is this indicative of a problem with the mag? Or are some just like that?

Thanks,

~AbM
Link Posted: 11/5/2003 8:21:13 AM EDT
Sounds like you have used them already but I would still do a few 'break in' things to them. Use a ruler and cycle them up and down about 20-30 times. Them load them by hand or lula to full capacity and let them sit for two weeks or so. This should loosen them up a bit. Yes i use a lula on mine and sometimes you just have get it on there and not worry about if its perfect. They are great mags especially for the price.
Link Posted: 11/5/2003 9:54:04 AM EDT
Actually, I have already done that after reading various "seasoning" techniques on this board. I can't tell if this one mag has any actual problems, or is just out of spec enough to mess with the LULA. ~AbM
Top Top