Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 5/11/2003 6:51:43 AM EDT
I'm not sure about the "new" stuff from Olympic. My ammo arrived Friday (5/09/03) from Midway. This morning (5/11) I and another officer from another dept. tried the SS109. Failed miserably in my duty 20" A2 (after ruling out gun, mags, etc.). His duty A2 SBR fed fine. Glad it wasn't my gun! After all the failures, burned a full mag of Blackhills with no probs. This ammo will not be shot any anymore of my weapons. Back to the old saying, you get what you pay for.
Link Posted: 5/11/2003 7:09:11 AM EDT
Describe the failure please. Case failure? priming failure? Bullet composition? More info please. Meplat-
Link Posted: 5/11/2003 1:03:04 PM EDT
Dear me, I just bought a brand new Colt Match Target m-4 and boy did I have problems with Olympic ss109 62gr!!!!!!! The stuff failed to feed, fire, and primers blasted off the shells and jammed up my whole gun!!!! The trigger group had 14 primers stuck in here and there. One point I fired one shot and the next jammed and there was a round halfway into the chamber STUCK! Why was it stuck? The primer was stuck in the chamber as well. WHAT A PAIN! I wasn't sure if it was my brand new m-4 or the GI mags but I'm starting to think this ammo was the cause of my probs at the range today. Never again.... need to find better 62gr stuff...
Link Posted: 5/12/2003 11:21:08 PM EDT
[Last Edit: 5/12/2003 11:26:07 PM EDT by Cpl_Punishment_10]
Meplat, I was mainly having extraction problems, but the bad extraction was slowing down the bolt which led to feed/out of time problems. I put a fresh mag of Blackhills in and burned it off in a very pissed but rapid fashion with no probs. In follow up, when I got to the house, I tore the gun down for inspection and found the bolt carrier was FULL of a nasty flakey ash that I've NEVER seen before. I only fired 37 out of 40 attempted rounds. In 6 years in the Corps, and 5 years on patrol, I've never been this mad at ammo. M4WU, based on the problems I had, I doubt very seriously it was your equipment. I would tear it down for a good cleaning though.
Top Top