Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 1/30/2006 6:46:35 PM EDT
I tried out my wife's new AR, it fired perfectly with my old magazines, but with the new mags I purchased from 44mag, it would not chamber nor would the bolt close (even using the assist).

When I used those same mags in my AR - they functioned fine.

Would iot be better if I just broke in her magazines for her?

Thanks,
Kenny
Link Posted: 1/30/2006 6:47:46 PM EDT
Link Posted: 1/30/2006 6:55:14 PM EDT
It would not feed correctly and the lips at the top of the magazine had wear spots. They functioned perfectly in my old Oly Arms, but her Superior Arms lower/Bushy upper just would not feed right.

Her's worked perfectly with my old mags, not a hitch.

It was weird.
Link Posted: 1/30/2006 6:56:07 PM EDT
Important question - What brand mags are they?
Link Posted: 1/30/2006 6:56:14 PM EDT
mag sets too high in the mag well and probably has feed lips that are excesively high anyway, they are rubbing the bottom of the bolt...
Link Posted: 1/30/2006 7:29:11 PM EDT
Are they 20rd magazines? I got some from 44magcom and have the same problem, the mag lips catch the bolt.
Link Posted: 1/30/2006 9:03:59 PM EDT
[Last Edit: 1/30/2006 9:04:26 PM EDT by eklikwhoa]
either mag catch hole is off or feedlips too tall, i would send the mags back or contact them
Link Posted: 1/30/2006 9:37:06 PM EDT
44mag folks will take care of you. They are top notch.
Link Posted: 1/30/2006 10:45:34 PM EDT
Check the distance the mag catch is down from the top of the lower with the prints.
Top Top