Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 5/27/2003 10:52:42 PM EDT
Never seen this before, occasionally when pulling back the charging handle, the bolt will hang up, Ill let it forward and try and charge again and it still hangs up..This is not happening all of the time, maybe 40% of the time. Similarly, if I ride the bolt forward Itll hang up on the way closed pretty much in the same spot. I know not to ride the bolt closed, but my Bushmaster as a comparison does not have this problem.. Loose carrier key??
Any other suggestions? ( No hang ups at all while firing)
Link Posted: 5/28/2003 3:53:01 AM EDT
What kind of rifle is it? Is it hanging up when pulling back on the charging handle, or when you let the bolt carrier return on its own? You said that you will let it go forward but it will still hang up when you try again. How is that you get it to stop hanging up?
Link Posted: 5/28/2003 4:02:33 AM EDT
What does it do with no magazine in the rifle? Same problem, or no problem? If the problem occurs with no magazine inserted, then the first thing I'd suspect would be the buffer spring, and then I'd check to see that the correct buffer is installed. Then I'd inspect the bolt and carrier for anything unusual, especially checking for wear marks in odd places. Then I'd inspect the interior of the upper receiver and in the barrel locking lugs. It could even be a matter of fouling building up in the lugs. If it only hangs up when a magazine is inserted, that points to a magazine catch problem or a defective magazine. Once in a blue moon, you'll encounter a lower receiver where the mag catch slot is milled too high in the receiver, which can cause some mags to cause problems, yet they'll work perfectly in other rifles. I've only seen that problem once, but it's worth checking if the problem isn't found by other means. CJ
Link Posted: 5/28/2003 4:43:37 AM EDT
Its an Oly, 1993 mfg, problem surfaces both with and without mags. If the hang up arises I literally pull back th charging handle rapidly 2 or three times (like I am pulling a pull start) and I am able to charge at that point. Fit between upper and lower are super tight at the rear pin, almost need a punch to push the take down pin thru, and slightly looser at the front(dont need anything but a finger).Upper and lower are both Oly, so its not a frankengun. Look at the weapon on its side and light is slightly visible thru the recievers mating line at the front, and none visible at the rear takedown. So a super tight fit between the two. No problems / hangups while firing..
Link Posted: 5/28/2003 4:59:53 AM EDT
Could be a slightly bent gas tube.
Link Posted: 5/28/2003 6:44:20 AM EDT
Good call on the bent gas tube. That's the next thing I was going to suggest. Or it could be the snorkel on the carrier. Check to make sure that the tube is straight and the snorkel is undamaged and the bolts are still tight and well staked to the carrier. Take the lower off the upper. Push the carrier into battery by hand several times and see how it feels and works with no lower receiver attached. This will eliminate any possible hammer interference issues. CJ
Link Posted: 5/28/2003 6:55:57 AM EDT
Originally Posted By gmtmaster: Never seen this before, occasionally when pulling back the charging handle, the bolt will hang up, Ill let it forward and try and charge again and it still hangs up..This is not happening all of the time, maybe 40% of the time. Similarly, if I ride the bolt forward Itll hang up on the way closed pretty much in the same spot. I know not to ride the bolt closed, but my Bushmaster as a comparison does not have this problem.. Loose carrier key?? Any other suggestions? ( No hang ups at all while firing)
View Quote
Sound more like a problem with the charging handle if you have no problems while firing. Check the handle and channel in the receiver to make sure you're clean and nothing binding.
Link Posted: 5/28/2003 7:27:07 AM EDT
Never heard it called a snorkel before.
Link Posted: 5/28/2003 7:31:16 AM EDT
Now ,this is why I love this website. Thanks for all of the ideas, Ill check the gas tube and carrier key, I am pretty sure the buffer is the correct one but Ill look at that one also. Thanks for the help! John
Link Posted: 5/28/2003 7:58:13 AM EDT
I have another idea to throw into the mix. When I got my Eagle Arms Preban it had an A1 Carrier with an A2 Upper, when I switched out for an A2 carrier the Forward assist was hanging on the slots cut into the carrier. I just needed to oil the forward assist and work it a couple times. Before I did that it was doing the same thing, I would pull back and it would hang up then I would have to jerk it a couple times and it would free itself (like you're pulling a pull start) might want to try that. Hope that helps.
Link Posted: 5/28/2003 9:55:36 AM EDT
Gotcha on that one, Ill check it out.. Hope its nothing big, just got back from the indoor range here in Omaha, this 11.5 oly is one accurate beast, shoots better than my 20" Bushmaster. Thanks for all the input.. John
Link Posted: 5/28/2003 2:17:13 PM EDT
Another thing to look at: Make sure when you are pulling the charging handle back that you aren't applying downward pressure. You may be causing the handle to catch on the top of the lower receiver.
Link Posted: 5/28/2003 4:46:21 PM EDT
[Last Edit: 5/28/2003 4:48:30 PM EDT by sharpshooter33]
ok I will throw another one in the pot. I had some problems with a firing pin key. I had it turned slightly and it was protruding alittle more than usual. About half way back it would hang up. Just another $.02
Top Top