Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Arrow Left Previous Page
Page / 2
Posted: 12/9/2003 1:40:54 PM EDT
We have two XP Pro systems connected by two 10/100 NIC cards with Cross-over cable. Both systems have Pro and I have limited Networking skills. I don't need to share the internet connection I just to connected the two computers so I can move some files over while I format and then bring them back afterwards.

I need to know what protocols need to be installed on the LAN connection and if I need to set up IPs.

So a basic outline of setting up a network where I can share files would be great.

Thanks to anyone who can help.

Link Posted: 12/9/2003 1:44:21 PM EDT
[Last Edit: 12/9/2003 1:47:21 PM EDT by MadProfessor]
You need to install File and Printer Sharing for MS Networks on each computers network connection in the proper control panel Each PC will need a IP address I think, install TCP/IP anyway, might as well Am I forgetting anything? This is sad, I havent done it in so long I dont remember exactly how.
Link Posted: 12/9/2003 1:46:37 PM EDT
I've done both of those but the computers are not recognizing each other. Is there a certain format that the IPs need to be in?
Link Posted: 12/9/2003 1:49:27 PM EDT
They need to be in the same network Make one 192.168.1.1 and the other 192.168.1.2 Then you put the files you want to share in a folder, right click it, Go to properties, Sharing, Share this folder
Link Posted: 12/9/2003 1:51:03 PM EDT
Ok thanks, they're connected but I'm not able to see information between them. I'll try the IP thing right now.
Link Posted: 12/9/2003 2:55:22 PM EDT
Ok not working..... Anyone have any good walkthroughs..... I'm really getting frustrated..... Want to throw POS Dell through Window.....
Link Posted: 12/9/2003 3:05:32 PM EDT
Have you considered running the Network Setup Wizard that is built into Windows XP? Open up My Network Places and click on Setup a home or small office network. Then just follow the directions. Do it on both computers. If you don't have My Network Places, right click on the Start menu icon, select Properties, Click on Customize, Advanced, then click on My Network Places to add it to the start menu. That way it will be there when you want to use the connection, too.
Link Posted: 12/9/2003 3:07:05 PM EDT
I've done that about 20 times on each computer and never get both computers recognizing each other.
Link Posted: 12/9/2003 3:13:15 PM EDT
Instead of TCP/IP, try NetBEUI. That is a general network protocol and usually works even if TCP/IP doesn't.
Link Posted: 12/9/2003 3:19:27 PM EDT
Would this protocol be located on the Windows XP disk?
Link Posted: 12/9/2003 3:32:13 PM EDT
[Last Edit: 12/9/2003 3:34:23 PM EDT by PaDanby]
It should be. It may already be installed. I think it installed with 98. You just need to go to get it. in 98 its Settings - Control Panel - Network - Configuration - Add - Select Protocol you should find both TCP/IP and NetBeui. It might also be on the NIC caard disk. You also have to enable file and printer sharing on each machine, not sure where it is in XP. In 98 you then have to log on via the netork log-on screen. XP is probably similar. It will be in the Help screens and if not then Practical Networking (google it, I lost my bookmark) has all kinds of troubleshooting and installation guides. I think I saw it in the lessons on www.jefflevy.com the otherday.
Link Posted: 12/9/2003 3:41:51 PM EDT
okay here you go. I'm asumeing you have done the following 1. CROSSover cable hooked nic to nic. 2. enabled file and print sharing. 3. ip address on PC #1 to 192.168.1.1 subnet mask 255.255.255.0 4. ip address on PC #2 to 192.168.1.2 subnet mask 255.255.255.0 5. set no gateway right? more to follow
Link Posted: 12/9/2003 3:43:17 PM EDT
now, what you're trying to do is 'see' each others files?
Link Posted: 12/9/2003 3:44:46 PM EDT
Ok I can't find it on the Windows disk, I have NetLinkBIOS and the other one installed along with TCP/IP.
Link Posted: 12/9/2003 3:48:09 PM EDT
goto Start>Run> type '//192.168.1.1 from pc#2 or if you want to 'see' or browse to see each other. go to Start>search>file named lmhosts.sam
Link Posted: 12/9/2003 3:52:57 PM EDT
and then edit the file and save, make sure it's not saved as a text file. scroll down and you'll see the nameing scheme
Link Posted: 12/9/2003 3:54:36 PM EDT
[Last Edit: 12/9/2003 3:55:35 PM EDT by Energizer]
You may not be able to browse the other computer's resources. Try this: 1. Open Windows explorer on one of the machines. 2. Type \\ipaddress_of_other_machine in the address bar 3. Look for shared folders. If none are defined on that machine, add \c$ or \d$ (i.e. \\192.168.1.100\c$) to get to each of the drives as the administrator (you must log in when prompted). If you do not see anything, the firewall on the system you are trying to access may have been activated. Turn it off. 1. Go to your network connections 2. Right-click on the connection for your network adapter (i.e. Local Area Connection) and select properties. 3. Click the Advanced TAB and verify the Internet Connection Firewall is unchecked. Does this help?
Link Posted: 12/9/2003 4:00:18 PM EDT
This low tech solution works when I do not have access to network stuff. Pull the drive from the machine you want to reload. Put it into the good computer as a SLAVE drive. Boot the good computer. Move the files from the slave drive to the good drive. Turn machine off. Put HD back into machine and format. Once it is up and running pull the drive from the good machine and run it as a slave in the new machine. Low tech but it always works for me.
Link Posted: 12/9/2003 4:01:33 PM EDT
C:\windows\system32\drivers\etc\lmhosts add 192.168.1.1 pc1 192.168.1.2 pc2 or whatever names you want to use
Link Posted: 12/9/2003 4:07:00 PM EDT
Originally Posted By roptics: This low tech solution works when I do not have access to network stuff. Pull the drive from the machine you want to reload. Put it into the good computer as a SLAVE drive. Boot the good computer. Move the files from the slave drive to the good drive. Turn machine off. Put HD back into machine and format. Once it is up and running pull the drive from the good machine and run it as a slave in the new machine. Low tech but it always works for me.
View Quote
I usually do this as well. I even have 2 removable drive bays in my system for this very reason... [:D]
Link Posted: 12/9/2003 4:21:21 PM EDT
Ok I assigned the IP 192.168.1.1 to this computer and the other is 192.168.1.2 And cannot ping myself or the other computer but when I went to change the IP of the first one and it was the same as the other one and it wouldn't let me because it said the IP was already in use. So something's working and something isn't Thanks so much, you guys have really pitched in to help me.
Link Posted: 12/9/2003 4:33:50 PM EDT
Sniper- Run through this list line by line: This is a general list of things to verify if experiencing Peer-to-Peer networking problems All systems are part of the same workgroup All systems have different computer names. All systems are using the same protocol and preferably only one (e.g. TCP/IP). If using TCP/IP, assign different IPs to all systems unless using DHCP. If using Linksys EtherFast Cable/DSL Router, see this link for support. This router uses DHCP. Make sure "Print and File Sharing" is enabled. Be cautious of these settings if using a broadband connection (e.g. Cable modem, ADSL...). Read this article to secure your Lan. You will need to share something (e.g. drive, folder, printer...). Make sure your "Primary Network Logon" is set to use the "Client for Microsoft Networks" in the network properties. If some systems are running Windows NT/2000/XP, make sure it has user accounts for the Win9x/ME systems. Make sure you log in on bootup. Don't hit cancel, enter a username and leave password blank if you want. The next time you bootup, hit OK or ENTER (Win9x/ME). If using Windows XP for some or all systems, read this article about blank passwords. If not using a hub, you can only connect two systems using twisted-pair cabling as long as it's a cross-over cable. Linksys has a good page that explains how to tell what type of cable you have. If your planning to share your cable or DSL internet connection, make sure the host system has two NIC (network interface cards). Read this article that explains why. Want to share your Cable/DSL connection? Read this article for details. Using Windows XP? Need help with file sharing? Read this excellent article with step-by-step instructions on how to do this. or go to: [url]http://www.mytechsupport.ca/support/topic.asp?TOPIC_ID=49[/url] Good Luck...
Link Posted: 12/9/2003 4:36:06 PM EDT
Originally Posted By Sniper_Wolfe: Ok I assigned the IP 192.168.1.1 to this computer and the other is 192.168.1.2 And cannot ping myself or the other computer but when I went to change the IP of the first one and it was the same as the other one and it wouldn't let me because it said the IP was already in use. So something's working and something isn't Thanks so much, you guys have really pitched in to help me.
View Quote
BTW, this problem is sooooo familiar to me I just can't remember my circumstance OR solution. :(((
Link Posted: 12/9/2003 5:02:23 PM EDT
Ok to answer a few questions, Both part of the same workgroup, When I'm trying hook them up I just do it directly with crossover cable taking the cable modem. Both have separate computer names, and I still cannot ping myself when I removed the NWLink/NetBIOS and just went with TCP/IP. Still nothing. I think I need NetBEUI but I don't have it on the systems. I don't know what to do from here.... [:(]
Link Posted: 12/9/2003 5:11:05 PM EDT
I don't know if this will help, but make sure you have shared the drives and/or folders on both machines. Only administrator shares are setup by default. i.e. c$. ByteTheBullet (-:
Link Posted: 12/9/2003 5:25:24 PM EDT
Yeah there are shared files on both drives, I've tried both combinations of protocols and still can't see the computers. Does anyone have a link to the NetBEUI protocol? I thought Windows XP Pro was supposed to be easy to network?
Link Posted: 12/9/2003 5:47:17 PM EDT
do both computers have the same setting for the workgroup name?
Link Posted: 12/9/2003 5:57:43 PM EDT
Yep, workgroup settings are the same. Is there any advanced settings/firewall thing that could be screwing this up?
Link Posted: 12/9/2003 6:59:39 PM EDT
Before I saw your post, I was just thinking firewall too. Is it off?
Link Posted: 12/9/2003 7:37:30 PM EDT
[Last Edit: 12/9/2003 7:39:36 PM EDT by Janus]
Forget TCP/IP all together it's not needed and overly complicates things, in your situation. HOW TO: Install NetBEUI on Windows XP: [url]http://support.microsoft.com/default.aspx?kbid=301041[/url]
Link Posted: 12/9/2003 7:38:21 PM EDT
Are you sure that you have a crossover cable?
Link Posted: 12/9/2003 8:04:02 PM EDT
Yes I'm positive it is Crossover Cable. I can't locate the NetBEUI on the Windows XP disk, any tips? It's not in the list I know I need to find it on the disk.
Link Posted: 12/9/2003 10:11:56 PM EDT
I take it you turned off all the firewalls. Netbui won't work it you want to add a router later on... It should take maybe 15-30 minutes to link these two boxes. delete and start over if you need to.
Link Posted: 12/10/2003 4:22:30 AM EDT
It won't let me delete the connections, even if I disable them. I know this shouldn't be hard but I cannot find NetBEUI on my Windows XP Disk, any other place I can get the Protocol for XP Pro? Yeah neither one of them have firewalls on, BTT for the day crew. Thanks again everyone, this is a very frustrating process. I'm at school right now so I can't do any work on it but suggestions are sitll welcome.
Link Posted: 12/10/2003 5:59:48 AM EDT
[Last Edit: 12/10/2003 6:02:40 AM EDT by XM777]
Originally Posted By EladEflow: I know this shouldn't be hard but I cannot find NetBEUI on my Windows XP Disk, any other place I can get the Protocol for XP Pro?
View Quote
Read the Knowledgebase Article link janus posted above:
This article describes the process for manually installing the unsupported NetBEUI protocol on a computer running Windows XP. The NetBEUI files will need to be manually copied from the Windows XP CD-ROM before NetBEUI will show up in the list of installable network protocols. Install NetBEUI on Windows XP [red]The files necessary for installing the NetBEUI protocol on Windows XP are Netnbf.inf and Nbf.sys. Complete the following steps to install NetBEUI: Insert your Windows XP CD-ROM into the CD-ROM drive and browse to the Valueadd\MSFT\Net\NetBEUI folder. Copy Nbf.sys to the %SYSTEMROOT%\System32\Drivers directory. Copy Netnbf.inf to the %SYSTEMROOT%\Inf hidden directory.[/red] NOTE: To make a hidden folder viewable, perform the following steps: Click Start, click Run, type Explorer, and then press ENTER. Click Tools, click Folder Options, and then click the View tab. Under Advanced Settings, click Show hidden files and folders under the Hidden files and folders Folder. Click Start, click Control Panel, and then double-click Network Connections. Right-click the adapter you want to add NetBEUI to, and then click Properties. On the General tab, click Install. Click Protocol, and then click Add. Click to select NetBEUI Protocol from the list and then click OK. Restart your computer if you receive a prompt to complete the installation. The NetBEUI protocol should now be installed and working. NOTE: %SYSTEMROOT% is a Windows environment variable that identifies the directory where Windows XP is installed (for example, C:\Windows). To view the value associated with %SYSTEMROOT%, as well as other environment variables, at a command prompt, type set, and then press ENTER. NOTE: After following the steps above you should be able to use NetBEUI on Lan connections, however you will not be able to use NetBEUI on a Remote Access Service (RAS) connection. RAS connections cannot use NetBeui.
View Quote
Link Posted: 12/10/2003 6:38:06 AM EDT
[Last Edit: 12/10/2003 6:39:19 AM EDT by Lion_Dog]
Are you sure the network cards are working ON EACH machine??? On the DESKTOP goto MY COMPUTER, right click, HARDWARE, left click, DEVICE MANAGER, left click. Look for NETWORK ADAPTERS +/- go to - to reveal device, right click device, Properties, left click... what does it say??? Like I said do for each. I checked my XP Pro HELP file here in office this is a NO-BRAINER even with TCP/IP, something wrong somewhere that you might be taking for granted. For some reason the documentation implied that an internet was "expected" by their arrangement, would this have www access? Edited: sp
Link Posted: 12/10/2003 10:39:50 AM EDT
Ok, let's start at the beginning, do you have link lights on both cards? This will confirm your physical connection. If you do not, you either have a straight through patch cable or a faulty cable or network card(s). If you do not have this link, you need not further troubleshoot into higher levels of troubleshooting such as pinging and protocols yet.
Link Posted: 12/10/2003 1:28:37 PM EDT
Just so there is no confusion, EladEflow and SniperWolfe are both trying to set up the network. There is a physical connection lights are on on both ends, and I don't know what I'm leaving out. It should be a no brainer I think.
Link Posted: 12/10/2003 2:26:42 PM EDT
You don't have the option of add/remove / properties on your network set up?? I wondering, if U tried it with the fire wall active- i wonder if it locked you out??? Is teh cable brand new?? Can you try a different cable??
Link Posted: 12/10/2003 3:28:25 PM EDT
You definitely have an internal/nic problem if you can't even ping yourself. Is this true on both machines?
Link Posted: 12/10/2003 3:44:47 PM EDT
ping 127.0.0.1 on both machines. This is the loopback address and will let you know if the protocol (TCP/IP) is working correctly w/o worrying about hardware. If the loopback ping works... then you have a physical layer issue. Get a new crossover cable for the hell of it. Even if you are certain the pinout is correct, it still may just be a bad cable. Start eliminating physical problems first. Oh, and if you get file sharing working - PUT A FIREWALL ON YOUR LAN! M$ File Sharing is the equivilent of lifting your kilt to the entire internet. At the least go to [url=http://www.zonelabs.com/store/content/home.jsp]ZoneLabs[/url] and get ZoneAlarm.
Link Posted: 12/10/2003 4:11:24 PM EDT
Ok sounds like a protocol issue, I just typed in Ping 127.0.0.1. And it says "Request timed out" Now what?
Link Posted: 12/10/2003 4:24:13 PM EDT
Ok I checked out the device manager everything is great on both systems. I believe it is in the software, but the thing is right now I'm using the same connection that I use just went from the Crossover cable used to connect the two NICs to the Patch cable used with the cable modem. I'm so lost right now [:(] It isn't the Crossover either because the computers can see each other and recognize that they have the same IP but I can't even ping myself using the loopback ping.
Link Posted: 12/10/2003 5:17:03 PM EDT
Ok I type "ipconfig" in the Command prompt get the IP for the NIC card (192.168.1.2) then type "ping 192.168.1.2" and it says Request timed out. So yes it is a relatively new cable and it worked before, but I still cannot ping myself using the IP it gives me or the reloop.
Link Posted: 12/10/2003 6:33:22 PM EDT
Snipe- did you check to see if the FIREWALL is off on both machines? Ping 127.0.0.1, ping your own IP address won't tell you if TCP/IP is installed properly.
Link Posted: 12/10/2003 7:11:13 PM EDT
Ok an update: With about an hour of work under the coaching of brasspile. We uninstalled both NICs/reinstalled them, uninstalled all of the protocols/options we didn't need leaving us with only Microsoft Client and TCP/IP. We used the IPs 192.168.1.3 and 192.168.1.4 on a subnet mask of 255.255.255.0 with the same Workgroup (MSHOME) and different computer names. We still cannot ping either computer or ourselves. The cord is verified to be Crossover cable, it has a sticker right on it, purchased new last year, Belkin brand. One quick question, could I test the crossover cable by hooking it up to the cable modem to the NIC? Would it work instead of the Patch cable? Because I'm starting to question the cable. Both computers are sending packets but neither is receiving. Well I don't know what to do at this point, I'm off to bed (EladEflow) thanks again for all of the help.
Link Posted: 12/10/2003 7:34:37 PM EDT
This is funny to watch
Link Posted: 12/11/2003 3:50:31 AM EDT
Originally Posted By roptics: This is funny to watch
View Quote
Yeah I know - [b]EladEflow[/b] has been the one posting on here and working on the network. I'm off to school - he asked me to bump it.
Link Posted: 12/11/2003 5:09:04 AM EDT
Here is a complete walk thru for what you want to do. Hope this gets you going. [url]http://www.cellarstoneindia.com/cable_pdf/Direct_CrossoverSC-_Windows_XP_To_Windows_XP.pdf[/url]
Link Posted: 12/11/2003 4:08:11 PM EDT
I went with the HDD solution and everything has worked great so far, just need to put this HDD back in Sniper_Wolfe's computer once it's done formatting and put his "essentials" back on his HDD. *cough*Dominatrix porn*cough*
Link Posted: 12/12/2003 3:36:54 AM EDT
[url]http://www.ar15.com/forums/topic.html?b=1&f=5&t=218389&w=myTopicPop[/url]
Arrow Left Previous Page
Page / 2
Top Top