Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
11/22/2017 10:05:29 PM
Posted: 8/9/2004 3:06:34 PM EST
OK gurus, gotta problem. I think I lost a spring or something in my PPK. The gun will fire one round, but it will lock back. Or when empty it will not lock back with an empty mag in it and if you flip it over it will lock back. Any thoughts to what could be causing this?
Link Posted: 8/9/2004 3:35:33 PM EST
[Last Edit: 8/9/2004 3:36:18 PM EST by Dave_A]

Originally Posted By PhatForrest:
OK gurus, gotta problem. I think I lost a spring or something in my PPK. The gun will fire one round, but it will lock back. Or when empty it will not lock back with an empty mag in it and if you flip it over it will lock back. Any thoughts to what could be causing this?



Mag problem???

If not, then you did indeed loose a spirng....
Link Posted: 8/9/2004 4:01:47 PM EST
There is an internal slide stop/release, sounds like to spring that holds it down during normal operation is missing/broken. Try Walther or e-gun parts.

Bill
Link Posted: 8/13/2004 6:23:34 AM EST
Is this a new PPK or an older model? I have noticed that when reassemblying the pistol one could bend some of the triger links if not careful. Possbile this could be binding the mechanism. Also, the S&W parts are not well finished and there could be a burr causing the spring to bind (assuming it is a S&W build). With the slide off and a mag in the well (empty mag of course) you should be able to see how the mechanism works or not works as in your case. Best of luck.
Link Posted: 8/16/2004 8:29:10 AM EST
There's a little spring that holds the slide stop "down."

When you take the slide off, the slide stop can fall out. (The slide keeps it in place). If you didn't notice the spring pop out and reassembled without the spring, my guess is that it would be behave as you have described.

The part you're looking for, most likely, is Number 31 here: www.e-gunparts.com/productschem.asp?chrMasterModel=2100zPPKS

Good luck.
Link Posted: 8/23/2004 9:32:00 PM EST
Thanks for the help guys. I'm gunna order that spring up and I think that will fix the problem.
Link Posted: 9/3/2004 5:38:55 PM EST
okay, not trying to hijack a thread...

I have a problem with my ppk/s. It seems completely ranom, when firing the hammer will lock. I have never been able to repeat it by hand, only true blow-back. The only way to clear it, is to remove the mainspring to release pressure off the hammer and then put it back together again. It was purchased new in 99 and I have lost all faith with it and have dumped it in the back of the safe until I can figure it out. Any help???

FMO
Link Posted: 9/4/2004 9:13:48 AM EST
FMO...

Lock how?

Lock back?

Lock forward?

Lock midway?

Are you sure the hammer strut is properly alligned?

Perhaps you should also check the spring and grip housing in which it rides for burrs, etc.

What does the trigger/sear do while your messing with the hammer?

Finally, have you verified that the two stubby little pins that the sear pivots on have not fallen out? (The grips are all the hold them on, and if you lost one you might not know it and it could do weird stuff).
Top Top