Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
11/20/2019 5:07:11 PM
Posted: 11/3/2009 2:44:27 PM EST
Gun is a model 31 with about 4-5k rounds thought it.

Lately the extractor seems to be getting weak. If I do a press check without the mag in, the round will drop out of the extractor and through the mag well. Also when I'm clearing the weapon, the round doesnt eject as it should. The round might eject 1-2 in above the pistol, or might just drop down the mag well like when I do a press check.

The gun hasnt had a malfunction while firing yet. Even if I load a round and fire it with no magazine, it still ejects like it should. I have 2 other glocks, another 31 and a 23, both hold the round tight until it hits the ejector. I replaced the extractor spring hoping that would solve the issue, but it didnt.

Anyone else had this issue? What could I look for to fix it? I along with about 3 other friends that are glock armorers have looked at it and cant find anything wrong.
Link Posted: 11/3/2009 2:51:00 PM EST
[Last Edit: 11/3/2009 2:51:15 PM EST by Melendez402]
Originally Posted By jon_7687:
Gun is a model 31 with about 4-5k rounds thought it.

Lately the extractor seems to be getting weak. If I do a press check without the mag in, the round will drop out of the extractor and through the mag well. Also when I'm clearing the weapon, the round doesnt eject as it should. The round might eject 1-2 in above the pistol, or might just drop down the mag well like when I do a press check.

The gun hasnt had a malfunction while firing yet. Even if I load a round and fire it with no magazine, it still ejects like it should. I have 2 other glocks, another 31 and a 23, both hold the round tight until it hits the ejector. I replaced the extractor spring hoping that would solve the issue, but it didnt.

Anyone else had this issue? What could I look for to fix it? I along with about 3 other friends that are glock armorers have looked at it and cant find anything wrong.
Have you tried replacing the extractor?

Link Posted: 11/3/2009 3:59:56 PM EST
Originally Posted By Melendez402:
Originally Posted By jon_7687:
Gun is a model 31 with about 4-5k rounds thought it.

Lately the extractor seems to be getting weak. If I do a press check without the mag in, the round will drop out of the extractor and through the mag well. Also when I'm clearing the weapon, the round doesnt eject as it should. The round might eject 1-2 in above the pistol, or might just drop down the mag well like when I do a press check.

The gun hasnt had a malfunction while firing yet. Even if I load a round and fire it with no magazine, it still ejects like it should. I have 2 other glocks, another 31 and a 23, both hold the round tight until it hits the ejector. I replaced the extractor spring hoping that would solve the issue, but it didnt.

Anyone else had this issue? What could I look for to fix it? I along with about 3 other friends that are glock armorers have looked at it and cant find anything wrong.
Have you tried replacing the extractor?



Got one on order now.Just wanting to get a few opinions if it could be something else.
Link Posted: 11/3/2009 4:22:22 PM EST
Had the same issue with one two years ago. It was the extractor. A piece had been chipped off and it wouldn't hold the round tight any longer. New extractor and spring, problem solved.
Link Posted: 11/3/2009 6:29:58 PM EST
You've got the new Extractor spring, put in the new Extractor, make sure it has the correct Extractor Depressor Plunger in the back, and make sur the Extractor Depressor isn't worn or damaged in any way (which is highly unlikely), then shoot.

Even if you're still having this looseness as you describe, the round "falling out" of the Extractor when press checking without a mag in place (which you normally would not do, when you think about it), as long as it shoots and runs reliably past that point, I wouldn't worry about it.

Most likely the new Extractor in conjunction with the new Extractor Spring will solve the problem.

Obviously you also want to make sure the area in the Slide where the Extractor rides is totally clean and free of debris while you're at it.
Link Posted: 11/4/2009 9:33:06 AM EST
[Last Edit: 11/4/2009 9:37:40 AM EST by Melendez402]
Originally Posted By ViniVidivici:
You've got the new Extractor spring, put in the new Extractor, make sure it has the correct Extractor Depressor Plunger in the back, and make sur the Extractor Depressor isn't worn or damaged in any way (which is highly unlikely), then shoot.

Even if you're still having this looseness as you describe, the round "falling out" of the Extractor when press checking without a mag in place (which you normally would not do, when you think about it), as long as it shoots and runs reliably past that point, I wouldn't worry about it.

Most likely the new Extractor in conjunction with the new Extractor Spring will solve the problem.

Obviously you also want to make sure the area in the Slide where the Extractor rides is totally clean and free of debris while you're at it.[img]http://www.ar15.com/images/smilies/icon_smile_wink.gif[/img]
Yeah most owners don't clean that area. I have a G27 and I recently acuired a G17 from a trade with another shooter. When I took it apart the extractor, depressor plunger and firing pin area was dirty as hell among other parts.

Top Top