Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
1/16/2020 9:48:49 PM
Posted: 10/8/2007 4:17:33 PM EST
I have a Phillips PSC703 sound card. It has worked well in the past, when I was running Win2kPro. Now that I have installed XP I can't get the drivers loaded. I get an error message saying the class installer has declined to install,...
If I boot up using the 2kPro I get sound.
What do I need to do now?

Jim
Link Posted: 10/8/2007 4:58:32 PM EST
[Last Edit: 10/8/2007 5:01:06 PM EST by cruze5]
you using xp compatible drivers ?

im trying to find some xp drivers for ya as we speak, one thing i hate about phillips

give these a try link
Link Posted: 10/8/2007 5:00:01 PM EST
Get xp drivers.
Link Posted: 10/8/2007 5:36:31 PM EST

Originally Posted By cruze5:
you using xp compatible drivers ?

im trying to find some xp drivers for ya as we speak, one thing i hate about phillips

give these a try link


I followed that lionk, clicked this- "Extracting complete. Click here for download.", clicked launch file after download manager said download was complete, went through the setup wizard to completion, restarted my computer and still didn't get sound.

Did I forget a step or do something wrong? Keep in mind that I am barely computer literate.

Jim
Link Posted: 10/9/2007 2:32:57 AM EST
no you did everything right.


to be honest i'd upgrade to a creative (soundblaster) sound card those phillips are not very good, there support sucks, and you can't get drivers, as you can tell.

you can take it somewhere to be looked at, but with their pricing it will be cheaper to buy a sound card. if you need help installing it we can help
Top Top