Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 4/8/2006 9:21:11 AM EDT
[Last Edit: 4/8/2006 9:21:33 AM EDT by John Parker]
I have downloaded the 1.12 patch and things were running fine. Now for about a week and a half the vast majority of servers I want to join kick me out. The message is that I have an older version of what they are playing now. What do I need in order to play on these servers? Do I need the Euro pack or something? Thanks
Link Posted: 4/8/2006 9:25:09 AM EDT
There is a newer patch out. Just go to the BF2 site and download the new one and you will be good to go.
Link Posted: 4/8/2006 9:26:01 AM EDT
I believe current is 1.22.

Download the full version instead of the incremental.
Link Posted: 4/8/2006 10:55:45 AM EDT
Thanks!!!!!!!!!!!!!!!!
Top Top