Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 10/25/2004 2:14:01 PM EST
I have a problem with my Kel-Tec Sub2000.

<­BR>

I CAN'T FIND ANY RAIL MOUNTS FOR THE DAMNED THING! The only thing available is like a 2" long picatinny rail that mounts on the END of the forearm.

Anyone know how I can get a damn rail system on this thing?




Link Posted: 10/25/2004 2:19:26 PM EST
I have the same problem. I have looked all over, even combed www.ktog.org and still no-go. I saw pictures of a rail that someone had put into the forend, but I can't seem to find it again. I am still looking, but if you find one, keep me posted.
Link Posted: 10/25/2004 2:36:57 PM EST
If anyone on the net knows, these guys do.
Link Posted: 10/25/2004 2:50:25 PM EST
Now, this is what gets me. This is, originally, why I asked:



Originally Posted By criley:
]

I have two of the older carbines - the Sub 9. Mine have machined aluminum receivers instead of the polymer ones.

Mine are great. Very accurate. Very reliable.

My pistols are just fine, too. I carry a P40 every day and it is reliable and accurate as well.

KelTec stopped making the P40 because the average owner could not operate it. It has a high power to weight ratio. Long, fairly heavy trigger pull. Many people were limp wristing the pistol.

There certainly were issues with the early pistols. KelTec customer service has been second to none. They would make the guns right if they had problems.



Link here

BTW, those are 30rd USA (!!!) mags in that picture. Owner of that gun says they function perfectly. Who'd a thunk?
Link Posted: 10/25/2004 3:16:51 PM EST
BTT
Top Top