Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/19/2017 7:27:10 PM
Posted: 6/7/2002 4:47:03 PM EDT
Okay, first off I know that I should know how to do this since I am trying to get a job in this field. I had it working once but for the life of me can't get it working again. Here goes......... I have two computers both running Windows 2000. They are attached via Cat5 as a workgroup. I am using internet explorer which is how I set up my internet connection thru using the wizard on the Host computer. The host computer has an ID of 192.168.0.10 the guest has an ID of 192.168.0.12. I can see each computer in Network Neighborhood. I can connect to the net on the host computer but not on the guest. I have used the wizard to set up connection via a lan but it still does not work. Any suggestions?? thanks Sgtar15
Link Posted: 6/7/2002 5:00:32 PM EDT
Originally Posted By sgtar15: Okay, first off I know that I should know how to do this since I am trying to get a job in this field. I had it working once but for the life of me can't get it working again. Here goes......... I have two computers both running Windows 2000. They are attached via Cat5 as a workgroup. I am using internet explorer which is how I set up my internet connection thru using the wizard on the Host computer. The host computer has an ID of 192.168.0.10 the guest has an ID of 192.168.0.12. I can see each computer in Network Neighborhood. I can connect to the net on the host computer but not on the guest. I have used the wizard to set up connection via a lan but it still does not work. Any suggestions?? thanks Sgtar15
View Quote
I'm not running W2k, but I seem to remember that you had to set up an internet sharing connection on the PC that is connected to the internet (192.168.0.10 ?). Then on 192.168.0.12, you have to define 192.168.0.10 as the default gateway so that all traffic that is not on the 192.168.0.xxx network is routed to the 192.168.0.10 PC that routes it to the internet. Hope that helps. Neil
Link Posted: 6/7/2002 5:06:32 PM EDT
I just realized, is your connection to the internet a dialup? Or is it Broadband/cable? If dialup, then the previous response should be valid. If Broadband/cable, do you have 2 NICs installed in the Host PC..one to connect to the Router, and one to connect to the home LAN..if this is yes, then previous response should be valid. If you only have 1 NIC, and the Host, Guest and Broadband connection is connected to the Hub, it won't work.
Link Posted: 6/7/2002 5:55:35 PM EDT
I tried all that crap! (I have several units in my network, 2 w/Win2K, 1 w/NT4.0, 1 w/XPpro and one w/98SE.) I Gave up and went with a router...everything humms right along now! [:)] I didn't have the kind of problems with Linux and Unix as the kind with windoze systems.
Link Posted: 6/7/2002 7:44:05 PM EDT
[Last Edit: 6/7/2002 7:45:16 PM EDT by Andrewh]
You will have to install internet sharing on the second computer. You need a 98 cd, and do a windows components install. It is in a sub set of the network or internet components. It is not defaulted as a checked component. You may have to do it on the main one as well. It requires you to set up what nic card you are using for your internet connection. Your main computer will use the one to your dial up or broad band connection, the second one will use the nic connected to your main computer as your internet connection.
Link Posted: 6/7/2002 7:46:53 PM EDT
Sgtar15, You say that guest has an ID of 192.168.0.12. How was it assigned? If this is a static entry, then that is your problem. When using ICS (on a 2000 box at least) you must assign IP's to the clients vis DHCP. -XM777
Link Posted: 6/7/2002 7:53:26 PM EDT
[Last Edit: 6/7/2002 9:07:07 PM EDT by XM777]
Originally Posted By Andrewh: You will have to install internet sharing on the second computer. You need a 98 cd, and do a windows components install. It is in a sub set of the network or internet components. It is not defaulted as a checked component. You may have to do it on the main one as well. It requires you to set up what nic card you are using for your internet connection. Your main computer will use the one to your dial up or broad band connection, the second one will use the nic connected to your main computer as your internet connection.
View Quote
Huh?? The only networking components required on the clients are: Client for Microsoft Networks Internet Protocol (TCP/IP) File and Printer Sharing Single NIC The host will require: Client for Microsoft Networks Internet Protocol (TCP/IP) File and Printer Sharing ICS Activated Two NICs (or NIC and Modem)
The host computer has an ID of 192.168.0.10
View Quote
Are you sure this is not 192.168.0.1? ICS should have assigned the host NIC that IP by default. -XM777
Link Posted: 6/8/2002 6:00:51 AM EDT
Originally Posted By 7IDL: I tried all that crap! (I have several units in my network, 2 w/Win2K, 1 w/NT4.0, 1 w/XPpro and one w/98SE.) I Gave up and went with a router...everything humms right along now! [:)] I didn't have the kind of problems with Linux and Unix as the kind with windoze systems.
View Quote
That's true! With Windows, each OS has its own 'peculiarities' (to put it nicely). But, if you are intent on playing around, another thing that I would try is to set the IP to something without a '0' as an octet. Perhaps W2k doesn't like invalid IP addresses. Sometimes Windows works with a '0', sometimes it doesn't. Depends on the OS, version and Svc Pack level. You can never tell and the only way is to dick around with it. Since you have a number of other PCs up and running, I assume you are aware of Gateways, subnet masks, protocol stacks, etc, and have verified all that info. And don't forget MS favorite trick. The software appears to install properly, everything configures correctly, but all features don't work until you de-install/re-install it. Good luck in any case...at least you have a work-around up and running.
Link Posted: 6/8/2002 6:10:41 AM EDT
tar send me an email, I'll have ya up and running in no time properly. Even if I [b]have[/b] to talk to you on the tele (i'm in Seattle presently).. lol /evil adim mode off
Link Posted: 6/8/2002 7:39:37 AM EDT
[Last Edit: 6/8/2002 7:43:03 AM EDT by BenDover]
sgtar15, are you multihoming the host (putting more than one NIC in it)? Or are you running What's your internet connection? Cable modem? Router? Need more info. I don;t have any of the trouble you guys are describing with Win2K running as a router on the gateway machine. I have a Cisco UBR router and I am running a single gateway proxy with 7 other machines inside the subnet. The proxy is multihomed with two NICs and I am running Win2k server on it with DHCP, Routing & Remote Access with Network Address Translation. DNS is running on a separate machine inside the subnet (domain controller). I have never encountered any issue prohibiting easy and quick connections to the network. Then again I am an MCSE & MCSD, but that shouldn't matter.
Link Posted: 6/8/2002 3:33:55 PM EDT
Bendover nailed it. Assuming a broadband connection, if you're running the internet connection thru the host computer, it has to be multihoned and act as the default gateway for the guest computer, which means it needs to act as a router for the guest. Do you have it set up this way?
Link Posted: 6/8/2002 8:45:02 PM EDT
[Last Edit: 6/8/2002 8:46:19 PM EDT by Joe_Blacke]
You say that you are running Windows 2000, and in a workgroup, so I am assuming that you are running Windows 2000 professional on both machines. If your machine that is connected to the internet (router), is running a Windows 2000 Server flavor, then it is best to use NAT rather than ICS. If you are in fact running on Windows 2000 Professional, then ICS is your only option unless you decide to buy a router. Next, if you are using a dialup connection such as AOL, or Compuserve, you can go ahead and stop trying. AOL and Compuserve have created their software so that it is impossible to share a single PPTP conneciton. To set up ICS, first set your client machine to obtain a IP address and DNS settings from a DHCP server. Your host/server/router will act like a DHCP server once you have ICS configured properly. On your router machine (the one running ICS), go into "My network places", and choose the properties of the connection that connects you to the internet. On the sharing tab, click on the box that says "allow internet connection sharing". Make sure you go into the "connections" settion of IE, and cler all the check boxes, EXPECIALLY for the "use Proxy Server" on both client and router. You should be good to go. On Windows 2000, the help files are outstanding. If you ever need a quick resource, Windows help is great. For additional help, come visit us at [url]mcseguide.com[/url]. There are some pretty knowledgeable pepole that hang out in the forums.
Top Top