Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
BCM
Member Login

Posted: 12/29/2003 6:00:31 PM EDT
Okay, I have a problem.

I have 3 computers, all running Windows XP.  I also have a D-Link wireless router conected to the main downstairs computer(C1) and PCI D-link network cards into the other 2 computers(C2&C3).

I have Cable internet that comes thru the router and all three computers are picking up the internet just fine.  However, I am not able to "see" the other compters and share files.  I have tried the wizard several times on all three computers but to no avail.

Ideas??

SGtar15
Link Posted: 12/29/2003 6:14:00 PM EDT
More than likely, your computers are not on the same subnet.  eg - your router is passing out internet visible IP addresses from your ISP to each computer, which have a different subnet (third octet of an IP address).  That's why my DSL provider does.  Best way around that (for many reasons) is to turn on NAT (Network Address Translation) on your router.  On the other hand, it could be that file sharing isn't installed on your client computers.  Are the running XP Home or Pro?
Link Posted: 12/29/2003 6:18:13 PM EDT
[Last Edit: 12/29/2003 6:20:40 PM EDT by PaDanby]
You need to enable file and printer sharing.  You also need (IIRC) to have all your Protocols installed on all the machines.  I believe this includes NetBeui and maybe Microsoft Sharing. I believe you need these in addition to the TCP/IP which since you are seeing Internet is in there OK. Check your "Help" on Protocols.


That's what I get for checking before answering.  Look at it this way.  You have 2 way comms between each machine and the router so all the hardware is working and at least some of the software.  Your almost there.
Link Posted: 12/29/2003 6:18:52 PM EDT
Make sure file and print sharing is turned on at all the PCs.  Additionally, make sure that all PCs are in the same workgroup.  If they are in different workgroups, they will not see each other.
Link Posted: 12/29/2003 6:19:03 PM EDT
Is it possible that you don't have "File and Printer Sharing for Microsoft Networks" activated on each computer ?

Go to your Windows XP Control Panel then Network Connections.  Right click on the connection for your LAN and select Properties.  In the "This connection uses the following items" you should have "File and Printer Sharing for Microsoft Networks" checked.

Your wireless router should be able to protect your computers inside the LAN for connections that originate from outside, perhaps by using NAT and firewall port blocking, but check the docs to be sure.
Link Posted: 12/29/2003 6:21:10 PM EDT
Xp Pro


Link Posted: 12/29/2003 6:25:39 PM EDT
okay....how do I turn on "file sharing"?

SGtar15
Link Posted: 12/29/2003 6:26:52 PM EDT
Illigb beat me to it.  If they're not in the same workgroup, they don't share common ground.  Even if you don't have print and file sharing enabled, you'll still see the local computers if they're in the same workgroup.  You won't be able to access  anything, but you'll still see them.
Link Posted: 12/29/2003 6:29:50 PM EDT
Make sure that all the computers are part of the same workgroup. This is in the "system" icon and "network Identification" tab in the control panel.

Once they are all part of the same workgroup or domain (if you use domains which isn't worth it for a few comps), open "Windows Explorer" or "My Computer" and select the folder you wish to share files.

Usually, browse to a subfolder with the files you want to share between comps. Highlight the folder, right click on it and select "sharing". Select the sharing tab at the top and select "Share this Folder".

Type in the name by which you will want to share the folder as (I.E. "Shared Crap"). You can select number of users to limit it to, but I would just use max. You can also change the permissions of accessibility and changeability of the files, but since this is your private network, I wouldn't bother as it defaults to everyone. Don't mess with caching.

If sharing isn't enabled on the computer, it will ask about turning it on. I don't exactly remeber the verbage.

The root drive and its' directories can also be shared, but it will by default be an invisible share as denoted by the "$" sign following the drive letter. You can share the entire drive by clicking on "New Share" and doing the preceding share name, etc steps.

Once the computers are all on the same workgroup, and shares have been created, you can see computer names and click to the shares in "network Neighborhood". I like to permanently map them to drive letters on each computer for easy access. But that is a holdover from my Novell days.

If you share printers, you will also see them in the "network neighborhood" browsing.

BTW: Don't use the default workgroup name (which is "workgroup") for the network computers as it is a severe security risk. Change it to anything other.

Notes: These instructions aren't step-for-step "exact" as it has been awhile since I did it, but it pretty close.
Link Posted: 12/29/2003 6:31:14 PM EDT
I had about the same setup and the same problem.
I have a Dlink DI-614+
I also assume you are using the DHCP from the router.
Can you ping the other computers? If not try this.

Go to the "Advanced" tab on the router set up.
Select "firewall" button
Make sure the Allow [source]Lan( Ip range in the DHCP )[destination] Lan,* [proticol TCP,* Is checked.
Link Posted: 12/29/2003 6:31:32 PM EDT
They're probably all on same subnet... doesn't make sense not to. Right click on My Computer on the desktop and then click Properties. Look for a Indetification or Computer Name tab and then make sure that Workgroup Name is the same on all the computers.

I forget exactly how to get to the bit about allowing users to share, you need to enable that "file and print sharing" mentioned above. You'll have to dig around control panel and the networking controls...

Good luck... I'm sure you'll do the one magic click and then suddenly everything works.
Link Posted: 12/29/2003 6:39:03 PM EDT
goto start button and select run
type "\\(computer name you want to connect)"
If the name of the computer you want to connect to in named main then type \\main

It does not matter on XP if File Sharing is enabled you should get a window pop up with this.
Link Posted: 12/29/2003 6:41:38 PM EDT
Ah dammit another wireless router.  I constantly tell people not to use wireless anything when dealing with networks.  The stuff is still to unreliable for my likes.  Sure you don't have all the cables and shit but a standard wired network is still the most reliable thing out there, not the mention the speeds are greater.  File sharing is enabled by default so the only reason it would be turned off is if you did it yourself.  I have seen some cases where winsock protocols have been corrupted and that will completely stop a network in its tracks.  DO make sure the computers are in the same workgroup.  Use something simple such as HOME or OFFICE.

-GL
Link Posted: 12/29/2003 7:05:42 PM EDT
[Last Edit: 12/29/2003 7:08:08 PM EDT by Xer0]
General-Lord There is absolutly nothing wrong with simple wireless networks for non-super secure home networks. Sure wire is faster and more secure, but it isn't any cheaper or easier if your home is not wired already. Try reading arfcom on the shitter when there isn't a wire leading to the bathroom. Try being out on the back porch when there isn't a wire outside.

Since you can't add any help to sgtar15 other than to bitch about wireless networks, don't add anything at all.

Edited: Sorry Gen Lord, Just realized I was in a bad mood and shouldn't have replied in the harsh tone. Just got done attempting tech support from some damn Indian call center agent who can't speak english for crap.
Link Posted: 12/29/2003 7:15:53 PM EDT
Link Posted: 12/29/2003 7:36:45 PM EDT
If all of the computers are running TCP/IP (which they are if they can all see the internet), then you do not need to install IPX/SPX, NETBEUI, or any other PROTOCOL. All you need is TCP/IP. This is the most common PROTOCOL.
You need to verify that CLIENT for microsoft networks is installed, and that your computers are in the same WORKGROUP (just make up a name for this, and make sure it is the same on every box).
You also need to verify that the file and printer sharing SERVICE is installed.

If you wish to share a drive/printer/or folder, then  you need to make sure that sharing is enable on that drive/printer or folder. (just right click on the item, and go to properties, sharing should be one of the options on the menu)

That said..
To verify that your computers can communicate with one another try the ping test.
Go to start...
Command prompt...
Type in IPCONFIG, hit enter. Your ip address (the address the computer uses to communicate) will come up. Do this on all of your computers, and write down the addresses.

Now for the connectivity test...

Go to the command prompt. Type in PING then the IP address. Example PING 10.1.1.1
You will get a response similar to this if you are connected...

Reply from 10.1.1.1 : bytes=32 time=37ms TTL=64
Reply from 10.1.1.1: bytes=32 time=23ms TTL=64
Reply from 10.1.1.1: bytes=32 time=11ms TTL=64
Reply from 10.1.1.1: bytes=32 time=41ms TTL=64

If you get a response, then you should be able to do file and printer sharing. This means that your machine can talk to the other machine on your network.

if you get a request timed out, your machines cannot talk to one another for some reason.

Hope this helps.. If you want, e-mail me, I can give you a phone number, and I will walk you through it over the phone.


Top Top