Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
10/20/2017 1:01:18 AM
9/22/2017 12:11:25 AM
Posted: 9/6/2005 9:35:01 PM EDT
In October of 2001 I had a Janitrol combination A/C / gas heat package unit installed on the roof of my house, model PJG048075-1. It ran fine throughout October (it's hot here in Tucson until the end of October, normally), and then the gas heat worked well over the winter. First warm day of summer, no A/C. Apparently the condenser coil was bad from the factory. After a Keystone Kops series of "repairs" the vendor finally got a warranty replacement coil and fixed the damned thing.

It ran fine for the next couple of years. Last year it frapped on me again, but that time it was apparently just a loose wire on a contactor.

Tonight, it quit again. I could hear the compressor running, but no blower. I have no idea how long it ran like that before I checked it, but I'm more than a little pissed.

I'm going to call a service company to come check it out tomorrow, but if it's fucked I want a recommendation for what to replace this piece of crap with. Something quiet and RELIABLE!
Link Posted: 9/6/2005 9:37:29 PM EDT
That sucks big time.

I guess you could keep trying to get your money's worth but at the rate your going, it might be better to start fresh if the unit cannot be trusted.
Link Posted: 9/6/2005 9:38:44 PM EDT
Move north?
Link Posted: 9/6/2005 9:39:12 PM EDT
[Last Edit: 9/6/2005 9:40:28 PM EDT by WildBoar]

Originally Posted By KBaker:
In October of 2001 I had a Janitrol ................



Thats your problem right there.

and do not get a Goodman for a replacement. Its the same piece of crap.
Link Posted: 9/6/2005 9:40:14 PM EDT

Originally Posted By WildBoar:

Originally Posted By KBaker:
In October of 2001 I had a Janitrol ................



Thats your problem right there.

I'm quite f'ing aware of that. Unfortunately after shelling out serious dollars for it.
Link Posted: 9/6/2005 9:47:09 PM EDT
Oddly enough, I have 20+ years in the trade, and have Janitrols in my own house. The parts used are all off the shelf generic parts, nothing OEM. Very simple units and easy to fix.

You either have a bad blower relay, blower motor, or perhaps a clogged up air filter. There is a remote possibility that the unit may have developed a leak and is running a little short charged.


4 years is about average for some of the smaller parts to bite the big one. It also sounds like you need a better service outfit.

Ops
Link Posted: 9/6/2005 9:51:22 PM EDT

Originally Posted By Ops:
Oddly enough, I have 20+ years in the trade, and have Janitrols in my own house. The parts used are all off the shelf generic parts, nothing OEM. Very simple units and easy to fix.

You either have a bad blower relay, blower motor, or perhaps a clogged up air filter. There is a remote possibility that the unit may have developed a leak and is running a little short charged.


4 years is about average for some of the smaller parts to bite the big one. It also sounds like you need a better service outfit.

Ops

It's not the filter. I'm hoping for a bad relay. The blower motor is brushless DC. That translates to $$$.
Link Posted: 9/7/2005 5:03:16 AM EDT
Bump for the day crew.
Link Posted: 9/7/2005 9:36:27 AM EDT
[Last Edit: 9/7/2005 9:38:20 AM EDT by WildBoar]

Originally Posted By KBaker:

Originally Posted By WildBoar:

Originally Posted By KBaker:
In October of 2001 I had a Janitrol ................



Thats your problem right there.

I'm quite f'ing aware of that. Unfortunately after shelling out serious dollars for it.



Sorry to poke an emotional button on you.

Sheesh just thought I would warn ya about Goodman if you decided on another unit. But since you are so emotional and upset about the warning, I hope you get a Goodman.
Top Top