Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
12/15/2017 11:52:10 PM
Posted: 6/14/2002 11:55:23 AM EST
I'm having failure to extract problems with one of my carbine uppers. I've tried multiple bolts and the problem persists.

Four different types of ammo:

Barnul 62 gr steel case -- No Problems
XM193 -- No problems
M855 -- No problems
South African -- FTEs after every few rounds

Different magazines make no difference. The same lot of SA runs fine in a couple other guns.

Any ideas?

Link Posted: 6/14/2002 4:37:55 PM EST
All the problems point to a rough/sticky chamber, IMO. Try to find some way of having a detailed inspection of the chamber. I'm betting there's some areas needing polishing. My .02
Link Posted: 6/14/2002 6:31:30 PM EST
I agree with BobCole... If you have a chamber brush try using it every few rounds.. If that solves it, your chamber needs polishing...
Link Posted: 6/14/2002 9:43:04 PM EST

Originally Posted By bigyeti:
I agree with BobCole... If you have a chamber brush try using it every few rounds.. If that solves it, your chamber needs polishing...



How do you polish a chamber?

medcop
Link Posted: 6/15/2002 8:16:50 AM EST
How do you polish a chamber?

medcop


I used a cleaning rod in a drill with 600 grit wet paper then jewlers rouge on a swab attachment in the same drill.. Be careful not to exert any pressure on the sholder area... Better yet take it to a smith or send it back to the mfgr.
Top Top