Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
1/25/2018 7:38:29 AM
Posted: 8/10/2003 4:46:31 AM EST
First post, be easy. Any help would be greatly appreciated. I gotta RRA 16" varminter upper on one of Petes "US Property" stamped RRA lowers w/ NM trigger set. The trigger will not return after firing, I have to push it (the trigger) forward after each fired round. >:/ I followed a thread here and could not found the answer I was looking for. Have not taken the trigger out, is that a very big deal? Is this somethin that could be fixed be doin a little polishing? Thanks. That SEBR deal ROCKS
Link Posted: 8/10/2003 5:02:44 AM EST
Sounds like the trigger spring is either missing, installed incorrectly, or broken.
Link Posted: 8/10/2003 5:08:32 AM EST
Did it ever work? If you can push trigger forward and fire again, then it isn't disconnector or other issue. See neilfj's post above (broken/missing/improper install) return spring.
Link Posted: 8/11/2003 5:00:27 PM EST
Dry fire the gun and with the trigger stuck back open it up and look to see if the hammer is being held by the disconector.
Link Posted: 8/12/2003 4:42:24 PM EST
brasspile, no it has not ever worked properly. oldman, it is the disconnect that is holding it back. Any suggestions for a fix? Thanks for yalls help.
Link Posted: 8/12/2003 5:32:52 PM EST
Originally Posted By PowdRBurnZ: brasspile, no it has not ever worked properly. oldman, it is the disconnect that is holding it back. Any suggestions for a fix? Thanks for yalls help.
View Quote
Is the spring under the disconnector fully seated into the trigger channel? If it isn't down _All The Way_, it will make disconnector hang (you do have the spring there, right?). Is it adjustable trigger? Takeup adjustment stop could be adjusted too 'tight', back it off a turn?. Otherwise, is there something under the disconnector area (rear part of trigger) that is blocking it from full travel (piece of scrap metal in bottom of receiver, etc?)?
Link Posted: 8/13/2003 8:27:04 AM EST
[Last Edit: 8/13/2003 8:28:28 AM EST by dogcatcher223]
Pretty easy to swap out the trigger group if you are mechanically inclined even a little bit. and all that is holding in the disconnector is a pin. And there is a small spring between the disconnector and the trigger. Both are cheap to replace.
Link Posted: 8/13/2003 1:22:43 PM EST
I had the same problem with by A2 Bushy. I found a blown primer in the works. Removed it and then took all the fire control parts out, cleaned, inspected and lubed. Works better than ever. Sarge
Link Posted: 8/17/2003 7:05:52 AM EST
I recently had trigger and firing problems, and when i took a good close look I found 2 primer casings lodged in under the safety bolt that was preventing proper operation. Remmedy - use quality ammo!! Gil
Top Top