Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
1/22/2020 12:12:56 PM
Posted: 11/11/2012 3:10:03 AM EST
Greetings -
Recent purchase of a J & T Distributing Upper. First outing at the range yesterday and I'm having a problem with some factory loads chambering. Bolt doesn't go all the way home and then I have to fight to extract. If I get the first one to chamber then I can empty the mag without a problem. Got the bore light out to look at the chamber and I see RAISED concentric circles in the chamber. No where near as smooth as my other AR chambers. I've emailed J&T but haven't heard back from them yet. Any thoughts or comments would be appreciated.

Best Regards,
Richard

http://i261.photobucket.com/albums/ii71/trimadge/JT%20Distributing%20AR%20Upper%20Chamber/DSCN3412.jpg

http://i261.photobucket.com/albums/ii71/trimadge/JT%20Distributing%20AR%20Upper%20Chamber/DSCN3411.jpg
Link Posted: 11/11/2012 3:28:11 AM EST
I think you already know what the problem is. Someone ran that reamer hard or dry or something. Hopefully they'll fix you up.
Link Posted: 11/11/2012 3:48:54 AM EST
Thanks for the quick reply. Hopefully I'll hear from them tomorrow.

Best Regards,
Richard
Link Posted: 11/11/2012 8:24:56 AM EST
Link Posted: 11/11/2012 10:50:11 AM EST
Thanks Dano - Hopefully I'll hear from them this week. I have a couple of other J&T uppers and have been very pleased with the quality.

Cheers,
Richard
Link Posted: 11/11/2012 1:07:32 PM EST
Link Posted: 11/14/2012 1:20:37 AM EST
Thanks for all the responses. Tim and Nick were very responsive and had the upper picked up on their dime. Should have the replacement by next week.

Best Regards,
Richard.
Link Posted: 11/22/2012 3:42:47 PM EST
Received the upper with a replacement barrel. Chamber is smooth as it should be. Rounds chamber and eject perfectly. Gotta get it to the range to test. Nick, Tim, and Lee were very helpful. Getting ready to order another carbine upper from J&T. Great company to do business with. Thanks again for all the replies.

Best Regards,
Richard
Link Posted: 11/22/2012 4:13:28 PM EST
Originally Posted By RyJones:
I think you already know what the problem is. Someone ran that reamer hard or dry or something. Hopefully they'll fix you up.


OR ...maybe it wasn't finish reamed??
Either way that chamber is B-A-D.
Top Top