Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 9/16/2004 4:37:57 PM EST
[Last Edit: 9/16/2004 4:38:35 PM EST by triburst1]
Does anyone else have a problem with KAC RAS rail cover moving forward while shooting?

Is there a trick to keeping them from sliding forward under recoil?
Link Posted: 9/16/2004 4:51:36 PM EST
They should "Click" in with the rails.

Here's a test. Take it off. Now slide the rail cover on locking tab last. Slide it on until you feel the metal tab hit the rail. Now depress the tab lightly and slide it over the rail. Let go of the tab. Now continue pushing the rail on and listen for a "click" sound. Hear that and you are all set.
Link Posted: 9/16/2004 4:58:04 PM EST
The metal tab locks in with the first and last slot of the KAC rail systems. In other words, if your metal tab is in the middle of the rail system, it will have the ability to slide freely.

Scott
Link Posted: 9/16/2004 4:59:38 PM EST
Yeah, that is how I installed them but they don't click at all. I have tried them on three different brands of rails amd they don't engage on any of them. I wonder if the metal tabs are bent or too wide???
Link Posted: 9/16/2004 5:02:27 PM EST
[Last Edit: 9/16/2004 5:03:14 PM EST by Marksman14]
I bought alot of my panels used, and some of them had been stretched. It does happen. Squeeze em together a bit and see what happens. I'm interested in this as well...I've never heard of this happening on all covers. Do any of your panels lock? Did you get them all used?

You are using a KAC rail system correct?

Scott
Link Posted: 9/16/2004 5:07:22 PM EST
Link Posted: 9/16/2004 5:08:30 PM EST

Originally Posted By Lumpy196:

Originally Posted By triburst1:
I have tried them on three different brands of rails amd they don't engage on any of them.



Are you using them on KAC rails??? Not all rail systems have the cuts on the slots that allow the KAC panels to lock.



Didn't catch that...well that seems to be the problem...

I haven't tried it myself, but I doubt of KAC panels will lock onto other manufacturers rail systems.
Link Posted: 9/16/2004 5:23:18 PM EST

Originally Posted By Lumpy196:

Originally Posted By triburst1:
I have tried them on three different brands of rails amd they don't engage on any of them.



Are you using them on KAC rails??? Not all rail systems have the cuts on the slots that allow the KAC panels to lock.



Nope. I have seen them used on so many different systems, I assumed they worked on any picatinny rails.
Link Posted: 9/16/2004 5:31:59 PM EST
Link Posted: 9/16/2004 5:37:07 PM EST

Originally Posted By Lumpy196:

Originally Posted By triburst1:

Originally Posted By Lumpy196:

Originally Posted By triburst1:
I have tried them on three different brands of rails amd they don't engage on any of them.



Are you using them on KAC rails??? Not all rail systems have the cuts on the slots that allow the KAC panels to lock.



Nope. I have seen them used on so many different systems, I assumed they worked on any picatinny rails.



They wont work on other rail systems unless the notch of the rail is relieved on the inside to allow the metal tabs on the panel to click inside them.

I'll have to take a pic one day that explains it visually.



OK, thanks Lumpy.

Anyone have a set of rail covers they want to trade for some barely used KAC panels?
Link Posted: 9/16/2004 5:44:47 PM EST
My KAC panels work fine on my YHM 4 rail HG's. I slide them on then push down on the catch and slide the rest of the way untill they click.

triburst1, try sliding the panel in position where you want it. Then insert something under the catch and lightly pry up. You should hear the catch ends snap into place and the cover should stay put. Don't give up yet!
Link Posted: 9/16/2004 6:14:50 PM EST

Originally Posted By QUIB:
My KAC panels work fine on my YHM 4 rail HG's. I slide them on then push down on the catch and slide the rest of the way untill they click.

triburst1, try sliding the panel in position where you want it. Then insert something under the catch and lightly pry up. You should hear the catch ends snap into place and the cover should stay put. Don't give up yet!



Still no luck.
Link Posted: 9/17/2004 2:29:38 AM EST

Originally Posted By triburst1:

Originally Posted By QUIB:
My KAC panels work fine on my YHM 4 rail HG's. I slide them on then push down on the catch and slide the rest of the way untill they click.

triburst1, try sliding the panel in position where you want it. Then insert something under the catch and lightly pry up. You should hear the catch ends snap into place and the cover should stay put. Don't give up yet!



Still no luck.




Well that sucks! That little trick usually works. Did you pry up hard enough?
Link Posted: 9/17/2004 1:24:14 PM EST

Originally Posted By QUIB:

Originally Posted By triburst1:

Originally Posted By QUIB:
My KAC panels work fine on my YHM 4 rail HG's. I slide them on then push down on the catch and slide the rest of the way untill they click.

triburst1, try sliding the panel in position where you want it. Then insert something under the catch and lightly pry up. You should hear the catch ends snap into place and the cover should stay put. Don't give up yet!



Still no luck.




Well that sucks! That little trick usually works. Did you pry up hard enough?




GOT IT!

I finally got them locked on. Prying up in the center wasn't working but I tried using a small flat screwdriver on each edge and they popped into place. They are now very solid.

THANKS QUIB!!!
Top Top