Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Site Notices
11/20/2019 5:07:11 PM
Posted: 11/4/2009 12:52:14 PM EST
Ok went to sight in my new build, 6.8 spc 1x10. Fired first and only shot, the round FTE I had to get a brass rod to force it out and on inspection where the extractor goes it broke the rim off. Before I go any futher I want to try and find out what may be the problem. I am using Hornady V-MAX 110gr factory ammo. Waiting to hear from Manufacture which chamber I have, and what they used to test fire it. I cleaned it before taking it out. Should I try another round or just contact Hornady, If this lot of ammo is overloaded I don't want to blow up my gun.
Link Posted: 11/5/2009 8:27:15 AM EST
Originally Posted By okcaveman:
Ok went to sight in my new build, 6.8 spc 1x10. Fired first and only shot, the round FTE I had to get a brass rod to force it out and on inspection where the extractor goes it broke the rim off. Before I go any futher I want to try and find out what may be the problem. I am using Hornady V-MAX 110gr factory ammo. Waiting to hear from Manufacture which chamber I have, and what they used to test fire it. I cleaned it before taking it out. Should I try another round or just contact Hornady, If this lot of ammo is overloaded I don't want to blow up my gun.


Tore the rim off the brass ?

Was it difficult to punch out the empty brass ?

I know nothing about 6.8 SPC , but do you have the recommended buffer , tube & spring ? Correct gas port size for the rifle & barrel length ?

Did you clean the chamber ?

God bless
Wyr
Top Top