Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Page AK-47 » SKS
Site Notices
10/20/2017 1:01:18 AM
9/22/2017 12:11:25 AM
Posted: 8/20/2005 10:56:49 PM EDT
I have a Yugo SKS i just bought and it has some extracting problems. It can't quite eject the empty shells before the bolt comes back. Sometimes it just barely flips the shells out but normally they get caught in the bolt. I have a few other SKSs that shoot fine and this is the only one i have ever had trouble with. I understand how the grenade launcher system works so I know that is not the problem. I also swapped out all the internals from another yugo so I know that is also not the problem. I suspect its somewhere in the gas tube system but I was hoping someone could steer me in the right direction.
Link Posted: 8/21/2005 6:08:01 AM EDT
There is a block on the button for the grenade launcher sight. If the button is not ALL the way down in the locked position, the gas cannot come up through the chamber and work the piston.
Link Posted: 8/23/2005 12:11:57 PM EDT
could be the gas system is leaking or the chamber is rough or a little of both. Are you using laquer coated ammo? If so, try brass case or the wolf polymer coated and see if that helps. You might also check out your chamber for rust, etc.

I get stove pipes with laquer coated ammo after the chamber heats up.
Link Posted: 8/28/2005 4:56:41 AM EDT
my yugo was doing that as well.
my extactor was broken, after I replaced it it worked fine.
half the "claw" was gone.
Link Posted: 9/6/2005 7:54:58 PM EDT
[Last Edit: 9/6/2005 7:58:39 PM EDT by plinkereye]
gas leak/recoil spring-rod in bolt carrier on backwards/gas selecter broken/extractor spring too weak/extractor chipped/ejector not working/chamber corroded from last owner. try it with granade mode 10 rounds then try it semi-auto 3 rnd firing. and check your empty case to see for scratchs and use wolf polymer.
Link Posted: 9/10/2005 10:53:02 AM EDT
As has been posted,it could be a gas system leak at the cutoff valve/gas tube junction,however make sure the small piston and spring located in the rear sight block is clean of all cosmoline and the channel it moves in is clean.Crap in there can cause the bolt/carrier to operate sluggishly and cause FTE problems.Also has been stated,could also be a rough corroded chamber.If that looks to be the problem,take say a .45 borebrush,wrap it with a paper towel and put a small amount of polishing compound on the towel and turn the brush by hand with a cleaning rod and handle.Good luck
Link Posted: 9/11/2005 4:26:39 PM EDT
[Last Edit: 9/11/2005 4:29:22 PM EDT by CollegeBoy]
had problems with my yugo. after doing some research i figured it was probably the gas system. I put a piece of tape around the joint between the grenade launching switch and the gas tube. fired a round, the tape blew, which meant it was leaking bad. thankfully, the place where i bought mine let me "borrow" some parts

editted for spelling
they larn ya reel good at collage
Link Posted: 9/11/2005 5:03:10 PM EDT
what did you "exchange"?
the valve thingie?
Link Posted: 9/11/2005 5:04:12 PM EDT

Originally Posted By CB1:
what did you "exchange"?
the valve thingie?



gas tube, piston, and valve internals
Link Posted: 9/11/2005 5:55:12 PM EDT
good stuff!
share the range report when your ready
Page AK-47 » SKS
Top Top