Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 10/5/2005 10:23:03 AM EDT
I can't get my cleaning rod to go completely home in it's guide! It was completely seated when I picked it up from the gun shop a couple weeks ago, so I know it'll go in, but I'm stumped.

I've tried to screw it it (no go), jam it in, tap it in (gently) but all to no avail.

I'm pretty sure I'm just not doing something right, but danged if I can figure it out! It only lacks about 1/16" of seating. Anybody have any ideas??? (I feel like such a noob!) FWIW, it's a Vector underfolder.

Mike
Link Posted: 10/5/2005 10:53:33 AM EDT
take the top hand uard off and slide it in so you can see why its not going all the way in....I had a Galil type hand guard on an AK of mine recently and when you took the cleaning rod out you couldnt get it all the way back in. the holes werent lining up and maybe that s your problem....check it out.
Link Posted: 10/5/2005 12:45:31 PM EDT
Had to take off the bottom handguard too, but then it went. I'm still not sure, after looking at the internals where the screw end goes, what the problem is, but now I know how to get it back if it sticks again! Thanks.

Mike
Link Posted: 10/5/2005 1:11:36 PM EDT
Good...just in case the threads throw you the cleaning rod does not screw into anything. Should slip in and out freely once pulled over the lug.
Top Top