Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
9/22/2017 12:11:25 AM
Posted: 10/3/2005 2:27:20 PM EDT
I just bougth an Arsenal (Bulgarian parts) milled reciever SA M-5 "S" in 5.56x45mm and it came with an olive green waffle pattern magazine marked "5.56" that has a molded in "10" inside of a circle. I bought a second magazine that is identical except for the color; it is clear.

Here is the problem: it fails to feed about 10% of the time. I can chamber the 1st round (whether its the 1st of 30 or if there are only a couple of rounds in the magazine). It fires, but the following round gets stuck before the bullet reaches the chamber.

To clear this Malf, about half the time, I can just pull back the carrier handle & release by hand & it will chamber. However, several rounds woulf not feed and the bullets were pushed back into the cases (ruining the round).

I am using the new Polymer coated Wolf ammo, 62 grn hollow point. It also did this w/ some FMJ surplus 5.56 of mixed origin.

I am really not interested in switching ammo. That does not fix the problem here (and an AK that is only 80% reliable IS a problem). This is an AK; it should work with Factory ammo and all the other AKs I own (SAR-3 and Bulgarian SLR-95) work with all the ammo I have tried - including the new Wolf (heck, they worked with old Wolf). BOTH polymer 5.56mm magazines had this trouble. It did not seem limited to a certain round in the mag. It was just periodic. Frustrating.

Anybody had this trouble? Any ideas?

Also, assuming I can get this problem fixed, where can I buy more of the clear magazines?

Thanks guys.
Link Posted: 10/5/2005 5:52:15 AM EDT
[Last Edit: 10/5/2005 5:52:15 AM EDT by RS39]
same forum dupe
Top Top