Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Log In

A valid email is required.
Password is required.
Site Notices
6/21/2017 8:25:40 PM
Posted: 6/14/2002 12:55:23 PM EDT
I'm having failure to extract problems with one of my carbine uppers. I've tried multiple bolts and the problem persists.

Four different types of ammo:

Barnul 62 gr steel case -- No Problems
XM193 -- No problems
M855 -- No problems
South African -- FTEs after every few rounds

Different magazines make no difference. The same lot of SA runs fine in a couple other guns.

Any ideas?

Link Posted: 6/14/2002 5:37:55 PM EDT
All the problems point to a rough/sticky chamber, IMO. Try to find some way of having a detailed inspection of the chamber. I'm betting there's some areas needing polishing. My .02
Link Posted: 6/14/2002 7:31:30 PM EDT
I agree with BobCole... If you have a chamber brush try using it every few rounds.. If that solves it, your chamber needs polishing...
Link Posted: 6/14/2002 10:43:04 PM EDT

Originally Posted By bigyeti:
I agree with BobCole... If you have a chamber brush try using it every few rounds.. If that solves it, your chamber needs polishing...



How do you polish a chamber?

medcop
Link Posted: 6/15/2002 9:16:50 AM EDT
How do you polish a chamber?

medcop


I used a cleaning rod in a drill with 600 grit wet paper then jewlers rouge on a swab attachment in the same drill.. Be careful not to exert any pressure on the sholder area... Better yet take it to a smith or send it back to the mfgr.
Top Top