Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 1/10/2006 5:46:09 PM EDT
I have a P-1 that I bought last year. Alum frame, mfg date of 7/81, re-arsenaled in 94.

I am shooting hardball, target ammo in it.

The problem I have seen from different shooters is that many times after you fire the gun, the slide won't go fully back into battery position. You need to lightly push it with your shooting hand thumb and help it along that last 1/8" or so. Then it fires fine.

Sometimes it will do it one after the other and sometimes it will go thru a whole mag and have no problems.

I have tried winchester white box, CCI-Brass, and CCI aluminum cased ammo.

Had dif people try it to solve any limp-wristing issues that may be there, but that hasn't solved the problem.

Any suggestions?

Thanks
Rebel13
Link Posted: 1/11/2006 6:42:22 PM EDT
[Last Edit: 1/11/2006 6:43:18 PM EDT by dfariswheel]
Try better quality, different ammo. (This is the Number ONE reason for stoppages).

Clean the gun thoroughly ESPECIALLY the chamber.
Give the chamber a good scrubbing with solvent and a bronze brush.
Re-lube the gun with a good lube like CLP Breakfree.

Clean the magazine out.
MANY P1 problems are caused by sticky magazines. Be sure to reassemble them with the spring orientated EXACTLY like it came out.

Try a different magazine.

Replace the recoil springs with new FACTORY SPEC springs.
NO "extra power" springs, these can cause frame cracking. Use ONLY factory spec springs.

Clean/check the extractor.
Look for wear, fouling, chips, or burrs that might interfere with the round sliding up under it.
Make sure it's clean and operates smoothly with correct tension.

Check the breech face for anything that might cause the case head to not slide up it's face.

Check the chamber mouth for sharp edges that may be catching the case.
DO NOT start grinding on the chamber mouth, this will destroy the barrel.
If you suspect it's got a problem, let a gunsmith look at it.
Top Top