Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 7/1/2003 6:43:56 PM EDT

I have had problems lately w/ my Norinco leaving a light strike on the primers.
I'm using Wolf ammo, never had any issues at all with it. (other than the stench)
I just replaced the firing pin & the issue persists.
If I try the rounds in my SKS, no problem, fires every time.
I think the hammer spring may be weakened, but it shows no sign of this.
The issue also seems to be about every other round.
The only 2 things I can figure might be a problem are the hammer spring, or the hammer.
Hammer is slightly worn, but makes full contact with the firing pin, especially since I replaced it.
(the old firing pin was quite a bit shorter and a bit flattened at the tip)

Please let me know if you can offer any suggestions.

Thanks.
Link Posted: 7/1/2003 7:38:39 PM EDT
All I have for you is the simple stuff. Chamber clean? Barrel breechface? Firing pin channel in bolt?
Hammer springs are reasonably priced and substituting a known good (or assumed good)
part is an easy troubleshoot. Gives you a spare anyway.
Link Posted: 7/1/2003 7:42:33 PM EDT
Thanks msh,

I think I'll just order the spring. It's all clean, only about 5 rds through it since.
Looks like that spring will be a pain to swap out though. Any suggestions?

Thanks again.
Link Posted: 7/3/2003 8:22:36 PM EDT
[Last Edit: 7/3/2003 8:23:16 PM EDT by Dano523]
Pull the firing pin and clean the crap out of the channel. In the cleaning kit is a Small punch, use it to punch the retaining pin out of the middle of the bolt (at the lugs, pin is tapered and will only punch one way). If you don't get the channel/pin clean, then it binds up the distance that the firing pin can protrude forward.

Also, If needed, spin the firing pin and polish the taper section on the pin, this will allow the pin to protude slightly deeper due to the tapper limiting the distance that the pin can travel in the bolt.
Link Posted: 7/6/2003 8:02:21 AM EDT
Hi Dano523,

Thanks for the suggestion, I'll check the channel..

I cleaned the crap out of it, but may not have been able to see all the junk in there.
I'll let you know if that works.

Thanks!
Link Posted: 7/6/2003 10:12:56 AM EDT
I'm in Aurora and have next week off. Drop me a IM if you still have problems and I can take a look at the rifle and get it up and running without having to swap parts.

It will give me something to so between golfing my ass off for a week straight.
Link Posted: 7/6/2003 10:17:20 AM EDT
Thanks a lot Dano523!

I'll let you know.

Top Top