Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 5/21/2003 11:43:31 AM EDT
what happend yesterday. Me and 556sniper went shooting together for the first time in a while. I brought my SAR1 with my second RSA fcg in it. The disconector on the first broke, Ken at RSA replaced no problem.

So anyhow we went yesterday and I took my SAR1 with me to the range. It doubled on me a few times and like 556sniper said they don`t allow rapid fire at our range anymore.So I let him try a mag, he went through it no problems. So I said finish the other 2 mags off.He said cool. Starts shooting, he almost finished the mag when it took off. Couple minutes later the store gunsmith comes into the range. He saw the inside of the rifle nothing was damaged so I pulled the fcg and put the rifle away for the day.

I did NOT modify anything on the rifle and I did NOT change the factory setting.

Can I send the rifle and fcg to RSA? I ask this because this is the second problem I had with this. Now this isn`t a get down on RSA post and I understand s#it happens but twice?
Link Posted: 5/21/2003 12:53:53 PM EDT
Are you sure this was not a case of "bump fire"?
was the stock squarely shouldered and the trigger held in the rear most position? Or was there just a light touch on the trigger? Or did it just take off and he held on to the gun for dear life?
Link Posted: 5/21/2003 2:41:06 PM EDT
Check the setting on the disconnector.....sounds like your running loose and it may be bouncing.
Link Posted: 5/21/2003 3:00:19 PM EDT
Link Posted: 5/22/2003 5:50:12 AM EDT
tktm 556sniper said that when he went to pull the trigger it just took off and he held on to the rifle till it stopped firing. The trigger also had to be pulled completly to the rear most position for the rifle to fire. It felt like you had to pull it a little too far. Also I`m going to try sending the gun and fcg to RSA for fine tuning.
Top Top