Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 7/25/2003 7:32:54 AM EDT
I've got a SP2 GS series, less than 500 rds through it, setting up for coyote hunting this am I took it out to resight, chambered a round, would not fire, the safety lever would not shift, unloaded, took out rear pin, hammer woud not lock down, if I held it down it would not lock nor would the safety engage, took it home,disassembled, then it started working again, back to the woods, fired one round and did started again. Back home, broke it down, now it works, dry fired lower 100+ times and shifted safety repeatedly, worked every time. Any suggesstions?rk
Link Posted: 7/25/2003 2:19:10 PM EDT
Disregard, I pulled it all the way down, a primer cap had dropped down there and was hanging it up. Works fine now, rk
Link Posted: 7/25/2003 5:30:07 PM EDT
[Last Edit: 7/25/2003 9:56:06 PM EDT by Dano523]
Don't feel bad, we have all gone threw this one time or another. At least your rifle stopped working. I once blew a primer and had is jam the trigger just enough to stick the trigger in some sort of no mans land. The disconnector held the hammer just enough to retain it during cocking, but as soon as the carrier slammed home, the hammer slipped off the disconnector the rifle fired; over and over until the mag went dry. Had it not been a runaway, it may have been fun, but trying to hold the rifle in a safe direction, and go for the mag release to dump the mag (mag went empty before I got it out), is not my idea of a fun time.
Link Posted: 7/25/2003 6:05:47 PM EDT
I should have checked it out last time I fired it, it double tapped on me, but didn't do it again. I've been shooting some reloads that the primers weren't seating in tight, won't use any of them again in my AR. I'll save them for my single shot. Thanks rk
Top Top