Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 11/26/2003 2:27:58 PM EDT
Ok,

so I take my new TA-31 out to the range and everything shoots way left. With open sights, I'm dead on, with the Trijicon, I can't seem to get the adjustment to make any difference, I adjusted right until I felt the additional tension in the knob, then stopped, per the advice of the owner's manual, but I'm still hitting about a foot left.

It's on a flat-top with ARMS 19S mount.

Anyone else have a problem like this?

How did you solve it?

Link Posted: 11/26/2003 3:16:47 PM EDT
Not being an expert, it sounds like a warranty issue. When I started reading I was thinking it was not zeroed mechanically, but not being able to adjust it in it would be one of two things. 1. The gun 2. The scope Have you had any other optics on this gun? If not see if you can borrow someones just to see if you have the same issue. HTH
Link Posted: 11/26/2003 6:55:25 PM EDT
with iron sights, it shoots great. I have not had any other optics on this particular rifle. I'm planning on calling Trijicon at the first opportunity
Link Posted: 11/26/2003 7:15:47 PM EDT
Link Posted: 11/26/2003 7:31:12 PM EDT
Had similar problem with my TA 11F. Unable to sight in for windage. Sent it back to Trijicon for warranty repair. When I got it back windage was ok but was unable to sight in for elevation! Sent it back a second time - finally came back ok. Quality control seems to be a problem. New owners beware!
Top Top