Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 2/11/2006 5:01:33 AM EDT
Ive read the posts here and still dont quite know what to try.
Ive got a RR m16 with a LTM suppressed m169 upper, ramped and weighted bolt which also came from LRM. My problem is the gun does not function well on the first or second round but once she gets runnin... oh man! Ive tried to reduce the rounds in the mags but this doesent seem to be the problem( well it works pretty good when Ive got 10 or less but who would want that) Problem is not mag specific, ive several uzi and colt mags. Using haun mag block. Have switched out buffers and springs, as well as butstocks. The gun runs more reliably with a full stock on it, however Id really like to keep the magpull thats on it. Ummm lets see... standard m16 trigger package and hammer. Any thoughts gents?
Link Posted: 2/11/2006 7:50:23 AM EDT
[Last Edit: 2/11/2006 7:52:50 AM EDT by joe1972]
Joe Black come to mind.

www.m60joe.com/

He might be able to figure it out for you...
Link Posted: 2/11/2006 7:53:58 AM EDT
What exactly is it doing as far as not working right and what buffer are you using?
Link Posted: 2/11/2006 8:05:44 AM EDT
I believe I have solved the problem. I was running 124 gr loads at 1050 to 1100 the ported barrel in the lrm supressor was bleeding of just enough to make it not work reliably. Ive loaded a hundred rounds 115gr 1275fps and had no malfunctions. The gun was much more violent to shoot and uncomfortable in the trigger/ finger connection. Will try another 100 rounds here in an hour at 1200 fps. Why the trigger slapping my finger problem though?
Link Posted: 2/11/2006 8:54:57 AM EDT
What buffer are you running?
Link Posted: 2/11/2006 8:56:22 AM EDT
Trigger should not slap your finger, like an AK. Check your trigger assembly and make sure it is functioning properly.
Link Posted: 2/11/2006 10:00:56 AM EDT
slowed down to 1200 feels pretty good. did not notice any trigger slap, function was excellent.I question what is there to check on the m16 trigger?
Link Posted: 2/11/2006 10:10:29 AM EDT
I give up.
Link Posted: 2/11/2006 11:31:44 AM EDT
buffer is an acc hydrolic, but ive got standard 9mm buffers.
Link Posted: 2/11/2006 11:43:54 AM EDT
Original AAC buffer came with a very weak spring and wouldn't allow the use of the standard spring (too big for the spring to go around). The new ones you can use with either. Your trigger slap issue stongly indicates a weak hammer spring.
Link Posted: 2/11/2006 7:22:13 PM EDT
Thats pretty sage like advice. Ill swap out the trigger spring in the am.
Top Top