Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 4/11/2006 5:10:31 AM EDT
88 Ford Sable.I get in to go to work yesterday morning and as I always do with injected cars I turn the ignition to on and wait for the fuel pump to cut out.Well when I turn to the start position nothing happens and everything electrical goes out. The power door locks dont even work.No radio,no clock I mean nothing.As if someone disconnected the battery.I check the battery and it has 12.7 volts.Checked all fuses and cables and they all appear to be fine.The only thing I can think of is the ignition switch.I know these years of fords had a bad reputation for ignition switches.So what do you guys think.
Link Posted: 4/11/2006 8:06:12 AM EDT
There has got be be a relay that is activated by the ign. switch. If it is good, then that might point to the switch.

Those things are stacked three high in the pick your part. It might be time for a trip.
Link Posted: 4/11/2006 8:48:22 AM EDT
You know, the more I think about it the more this is acting like a burnt fusable link.I wonder if Ford put them in this car.The thing that has me wondering is I lost functions like the electric door locks that work no matter if the ignition is on or not.
Link Posted: 4/11/2006 7:02:11 PM EDT

Originally Posted By bwyatt:
You know, the more I think about it the more this is acting like a burnt fusable link.I wonder if Ford put them in this car.The thing that has me wondering is I lost functions like the electric door locks that work no matter if the ignition is on or not.



Usually they are on the battery cable right next to the pos. cable. Just pull hard on them and see if they pull apart.
Top Top