Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
PSA
Member Login

Site Notices
Posted: 1/29/2010 4:30:37 PM EDT
So I bought a new bushmaster AR and for whatever reason, the mag won't insert reliably if the bolt is closed, open the bolt, and all is fine.  Any ideas?  I'm about to take it apart, but I haven't heard of this problem yet.
Link Posted: 1/29/2010 4:31:33 PM EDT
Tag, because mine does the same thing. I never noticed it before this fall.
Link Posted: 1/29/2010 4:32:27 PM EDT
A full mag? Try downloading to 28 rounds or using a Pmag.



Empty, no idea why that would happen.
Link Posted: 1/29/2010 4:33:59 PM EDT
Mine does it empty and 2 short.
Link Posted: 1/29/2010 4:39:03 PM EDT



Originally Posted By mmajunkie:


Mine does it empty and 2 short.


It is going to be a bit harder with the bolt closed, but nothing a firm insertion won't overcome.



 
Link Posted: 1/29/2010 4:39:59 PM EDT
Mine inserts properly with 3 short.  I'm not new to this platform, and I have slapped the hell out of the bottom of a full mag and it will sometimes insert, but not normally full.
Link Posted: 1/29/2010 4:41:12 PM EDT
maybe the notch in the MAG is a bit off, and doesnt connect with the mag release properly ? or vise versa. have you tried multiple mags ?
Link Posted: 1/29/2010 4:45:54 PM EDT
I have been using the magazine that came with the rifle, but I did get a couple of Lancer(?) translucent magazines a couple of days ago, those do seem to go in fine with 30 rounds, I guess I gave bushmaster too much credit in thinking they would give you a decent magazine with the rifle.  Thanks for the help.
Link Posted: 1/29/2010 4:46:46 PM EDT
I have tried different mags and smack it hard, no idea.
Link Posted: 1/29/2010 4:47:24 PM EDT
[Last Edit: 1/29/2010 4:47:36 PM EDT by nobodyg17]
Originally Posted By 45ACP_Marine:
I have been using the magazine that came with the rifle, but I did get a couple of Lancer(?) translucent magazines a couple of days ago, those do seem to go in fine with 30 rounds, I guess I gave bushmaster too much credit in thinking they would give you a decent magazine with the rifle.  Thanks for the help.


Buy a metric ton of Pmags and call it a day.
Link Posted: 1/29/2010 4:59:49 PM EDT
OP what you are experiencing is not a defect with your BM.  Its an issue with all AR/M16 rifles.  If using mil spec alum mags just dont fully load mag (keep 2 off).  PMags dont have this problem.
Link Posted: 1/29/2010 5:08:03 PM EDT
Originally Posted By Larain60:
OP what you are experiencing is not a defect with your BM.  Its an issue with all AR/M16 rifles.  If using mil spec alum mags just dont fully load mag (keep 2 off).  PMags dont have this problem.


That's an interesting statement as I have never had that problem with any of the 16's that I was issued, nor my friends ar's.
Link Posted: 1/29/2010 5:14:18 PM EDT
Originally Posted By 45ACP_Marine:




Originally Posted By Larain60:

OP what you are experiencing is not a defect with your BM.  Its an issue with all AR/M16 rifles.  If using mil spec alum mags just dont fully load mag (keep 2 off).  PMags dont have this problem.




That's an interesting statement as I have never had that problem with any of the 16's that I was issued, nor my friends ar's.


its been my experience with a round in the chamber closed bolt trying to insert a full mag.  First realized it at a defensive carbine course and the instructor pointed it out on a few people's rifle there.  I didnt have that problem with the pmag



 
Link Posted: 1/29/2010 5:16:22 PM EDT
i only load 28 anyways
Link Posted: 1/29/2010 5:17:52 PM EDT
Link Posted: 1/29/2010 5:21:49 PM EDT
Sounds like every AR I've ever handled.
Link Posted: 1/29/2010 5:22:38 PM EDT
Originally Posted By builttoughf250:
maybe the notch in the MAG is a bit off, and doesnt connect with the mag release properly ? or vise versa. have you tried multiple mags ?


Yep, the mag is the weak link most likely, try filing down the top of the notch on the mag, I did this with some SA80 steel mags and they work just fine now.
Link Posted: 1/29/2010 6:49:25 PM EDT
Just ordered some PMag 30 MagLevels.   That should do the trick.
Top Top