Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
10/20/2017 1:01:18 AM
9/22/2017 12:11:25 AM
Posted: 9/26/2005 9:11:47 PM EDT
My MI two piece rail is not aligned with the top of my upper. I noticed this when I wanted to extend my eotech out further. The top MI rail is leaned slightly to the left just enough that is isnt aligned. Is there a fix to this?
Link Posted: 9/26/2005 10:17:14 PM EDT
how does it attatch?



if it attatches to the teeth of the barrel nut like im assuming then try and tighten/position the barrel nut differently within the paremeters that the gas tube has given you.

even the larue along with some others are like this. if the barrel nut is in place and the rail is slightly off you can tweak it through the barrel nut
Link Posted: 9/26/2005 10:22:43 PM EDT
I was afraid that would be a solution. It was a ***** to align the tube to begin with but I suppose if I want it aligned correctly I will have to mess with it.
Link Posted: 9/26/2005 11:13:48 PM EDT
well there is a bit of room for the barrel nut to move even with the gas tube installed but to be safe remove the gas tube.



the little bit of movement allowed will show a lot with the rail installed
Link Posted: 10/5/2005 11:17:05 PM EDT
[Last Edit: 10/5/2005 11:18:29 PM EDT by repub18]
Finally got sick of it and just disassembled it, put it on the vise and put it back together and now the top rail is alligned.. They actually fit a lot better than before. Thanks for the tip.

Link Posted: 10/6/2005 3:38:16 AM EDT
That's good to hear.
Top Top