Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 7/26/2003 2:38:46 PM EDT
[Last Edit: 8/20/2003 12:56:12 PM EDT by jimmybcool]
Well, I thought I had this figured out. NOT. Damn thing is annoying. Here is the deal.

I have a DsA SA58 Carbine with the X-stock. It is all stock DSA manufactured, no mods of any kind.

I have fired about 300 rounds through it now in attempts to make it reliable. I was also following directions from DSA that suggested getting at least 250 rounds of break in before worrying about it. I am using a variety of milsurp magazines and ammo.

I have also varied the gas setting. Even at full power, it is not 100% reliable. At less than full power it is almost guaranteed to exhibit a failure in every magazine.

The failure types are:

a) Mostly it short strokes and the bolt rides over the top of the next round instead of chambering. Or the next round starts to rise from the magazine, and stops the bolt from slamming home.

b) Sometimes, it fails to fully eject the spent casing.

c) Sometimes it stovepipes with the spent casing sticking straight out to the right.

I believe I am knowledgable enough to have properly lubed the weapon. And I am using quality milsurp ammo like Hirtenberger and Portugese. Even tried a bit of Federal Match ammo.

I am about ready to send it to DSA. Do any of you have any better advice?

Thanks
Link Posted: 7/26/2003 3:02:47 PM EDT
I'd polish the chamber and check the gas port diameter.
Which barrel does it have?

...if it's a DSA, send it back and make THEM fix it.
Link Posted: 7/26/2003 4:20:11 PM EDT
You have a lifetime warranty with your DSA, use it.

Link Posted: 7/26/2003 5:02:26 PM EDT
Thanks guys. I just cleaned it and carefully lubed it and NOT lubed it where speced. Tomorrow is another shoot. If it continues to cause trouble, I'll stick with the M16 all day. And send it to DSA.

Link Posted: 7/27/2003 8:32:56 AM EDT
You don't happen to have a Buffer Tech recoil buffer do you? I have seen cases where this was imporperly installed and it created exactly the malfunctions you are having. If you have one, either remove it completely or just make sure the little "feet" are underneath the upper receiver and not inside it.
Link Posted: 7/27/2003 4:11:39 PM EDT
Cliffy

How would I determine if I have this recoil assembly? It has the X-stock from DSA and no mods have been made that I know of.

Link Posted: 7/27/2003 8:48:34 PM EDT
The recoil buffer is the aftermarket device (usually light gray) that slip onto the back of the upper. You'll know if you have one because every time you remove the bolt and carrier the buffer it will fall out and get lost under the bench if you don't catch it hat
Link Posted: 7/27/2003 11:11:57 PM EDT
If the barrel has been cut down to 16" then the gas port should be .118", not the stock .098. Pull the front sight pin and gauge the port to figure out what size the port is drilled.

As for the chamber, polish it out to get it to shine. The stock surplus barrel/chamber may have gotten a little rough sitting in storage for so long.

On the mags, clean them and check the spring to make sure that they are not going south. Also, load two rounds and press down on the back of the case. The rounds should pop back up cleanly to the top of the feed lips. If they don’t IM me and I will tell you the tweak to save the mag springs.

Pull the butt stock and the recoil springs and give them and the inside of the tube a good cleaning/lube. It may be that the tube is full of Parkerizing flakes that need to be cleaned out. I just use a brush on a few rods and give it a good spin down the tube to make sure the inside of the tube is slick and clean, then chase it with a patch. To get the springs back in the tube, use a rod (straighten hanger) to guide the springs back down, but the tool works better if you have one.

As for lubing the bolt/carrier/ receiver, use grease, not light oil. Don’t forget to get the carrier hood/channels greased too. The gas piston should be left dry, it will self clean, and lube just attracts more fouling.
Link Posted: 7/28/2003 5:48:28 AM EDT
OK. I must not have this thing since nothing falls out when I disassemble. Current gas setting is 3.

What would be right to polish the chamber? Steel wool? Mr Dremel stays away from Mr Chamber at all times. And since this is a SA58, a new rifle, NOT a surplus STG, why would the barrel sit around or is this still valid?

I will check the buttstock tube. That I have not done.

I guess I can turn up the gas even more and clean the buttstock tube. If this doesn't work I am sending it to DSA. I am not going to void my warranty.

Link Posted: 7/28/2003 6:46:25 AM EDT
This is the buffer Cliffy spoke of, they run about 15 bucks.
You or someone else would have had to put it in, they dont some with the rifle.



Link Posted: 7/28/2003 12:00:48 PM EDT
Dredd308 is correct. That is the buffer I was talking about. See the little "feet" down on the bottom. I have seen cases where these were installed wrong and caused a number of FTE problems. If you don't have this, your problem lies elsewhere.

Being a new rifle and the SA58, you should probably send it back to DSA. Don't screw around too much with polishing this and that because DSA can then blame you later for problems if you can't fix them.
Link Posted: 7/28/2003 3:45:11 PM EDT

Originally Posted By jimmybcool:
Since this is a SA58, a new rifle, NOT a surplus STG, why would the barrel sit around or is this still valid?



Sorry about that, I thought the rifle was a STG, not a SA.

On my SA, the barrel chamber was reamed match 308, not 7.62 Nato (read tight as hell). I polished out the chamber to a mirror finish, which slightly loosened it up to it solved the cycling problems. Also, since this is a SA, don't worry about the action springs and tube, there brand new. But do pull the front sight post and check the barrel gas port.

With the chamber polished and the correct gas port size, your going to love your rifle and will trust your life on it over almost every other rifle you own. Once they run right, nothing will stop them, and with a adjustable gas system, all that is needed to keep it running past the 1000 mark, un-cleaned, is a another click on the gas knob.
Link Posted: 7/28/2003 4:29:49 PM EDT
OK. How do I polish said chamber? I have never done this before and don't want to use the wrong thing.

Link Posted: 7/28/2003 6:37:42 PM EDT
Jimmy, don't polish the chamber man, just send it back to DSA for them to fix for you. You spent alot of money on that rifle and you don't want to go screwing around with it when you can have them fix it for you!

Don't go voiding a lifetime warranty by WECSOGing it. (Wile E. Coyote School Of Gunsmithing).

Send it back, make them fix it.
Link Posted: 7/28/2003 8:20:18 PM EDT
Yeah. I'm gonna try one more time (yesterday was a bunch of guys with machine guns so I didn't really focus on this). This time, gas all the way. Blast away. See if it still jams.

Maybe try another ammo type. Gotta see what I got in the garage.

If it fails - back to DSA. I don't feel like working on it.

Shame of it is, this is a really cool rifle. With the Reflex on it I am hitting targets a long way out. Took some shots offhand at a 4'x4' steel target yesterday and got it 50% of the time. Oh, it is about 700-1000 yards out (don't know really).

Link Posted: 7/30/2003 12:57:53 PM EDT

Originally Posted By Dano523:
On my SA, the barrel chamber was reamed match 308, not 7.62 Nato (read tight as hell). I polished out the chamber to a mirror finish, which slightly loosened it up to it solved the cycling problems. Also, since this is a SA, don't worry about the action springs and tube, there brand new. But do pull the front sight post and check the barrel gas port.



I also have a SA58 and had the same problems until I learned about the Match chamber. DSA's catalog reads ".308 Winchester chamber", but it's cut to match or damn-near-match specs.

When I called DSA for help, they were appalled that I was running 7.62mm Port and Hirt thru their rifle. They recommended .308 Win commercial ammo ONLY.

I have 2 DSA STG's that eat milsurp like crazy, but I feed my SA58 only "good" ammo.

CKMorley
Link Posted: 7/30/2003 5:37:52 PM EDT
Well, I bought some cheap Winchester 308 today. Tomorrow I will try out all the combos. We will see.

FWIW, I do not feel that a DSA SA58 should require that ammo. It is a battle rifle, not a target rifle and should cycle with any Nato type ammo.

We shall see.
Link Posted: 7/31/2003 1:27:15 PM EDT
OK. Update. Still no good. Turning the gas all the way on reduces the number of failures, but does not eliminate them. Clearly, the gas system isn't cycling with enough force.

I am shipping back to DSA tomorrow. They built it - they can fix it.

Time will tell.

Link Posted: 7/31/2003 4:13:46 PM EDT
Jimmy is that a pic of your Fal on GD on the Fal post? What type of scope mount is that> is that one that replaces the original receiver cover?

Have you tried the rifle with the original receiver cover on?

The reason for all the questions is, I've seen post on the Fal Files, when some folks will suddenly have problems when they install certain scope mounts...... Something about squeezing the receiver in just a hair and binding the bolt carrier, keeping it from moving freely on the rails!

This will cause a lot of the problems you're having!


Just a thought!
Link Posted: 7/31/2003 4:32:27 PM EDT
Dru

Hmmm. Yes, my FAL has a scope mount reciever. Guess it could be at fault. Lucky for me it is a DSA part. If that is the problem they can replace that.

I'll let you know if that was it.

Thanks

Link Posted: 8/5/2003 11:35:46 AM EDT
Well, I will say DSA does get on it in a hurry. I shipped on Friday (or was it Saturday) 2 day air. Today, Tuesday, I get a call from them.

They have run about 60 rounds of various stuff through it already. They claim to not see any problems. Dunno. Maybe when he disassembled the rifle to check the gas hole something clogging it fell out of the way. In any case, they discussed ammo. Mostly I am using Port FN.

They are going to open the gas hole a tad and polish the chamber again. I probably won't get to shoot it again until late August. We shall see.

I liked they are working hard on it. I don't like they didn't see the same problems.
Link Posted: 8/14/2003 10:35:09 AM EDT
hmm your problem is perplexing... I had some of the same issues with my SA58 for about 60 rounds.... After that, however, I have been able to turn down the gas and have no cycling problems at all...I have used nothing but sealed port milsurp from battle packs...once you get your rifle back and working, give us an update and let us know what the problem was...if known, of course....good luck
Link Posted: 8/20/2003 12:55:37 PM EDT
OK. Latest Update.

Today, the 20th, I got my rifle and shot it. I am not sure when they finished with it and shipped it as I was out of town a week and then the FFL I used to recieve it for me since I was gone left for a special event. So, the turn around was probably good, I just don't know.

On the work order, they have adjusted the gas port (which I think means expanded the hole), checked headspace, and polished the chamber.

Today, I took it to the range. I tried Port, SA, and commercial PMC in a variety of magazines.

No matter what I did the rifle fired and functioned flawlessly. The gas is set at 5 and I'm leaving it there.

Thanks DSA.

Link Posted: 8/20/2003 5:54:18 PM EDT
Good to know they made it right for you!!

Enjoy your rifle!

Link Posted: 8/22/2003 7:49:57 AM EDT
Glad to hear everything worked out.

I love my SA58 carbine.

Did you get one with a camo job? Mine is done in Tiger Stripe.
Link Posted: 8/22/2003 10:09:41 AM EDT
sweetness
Link Posted: 8/22/2003 12:15:26 PM EDT
Yup. Shot it again yesterday. Sweet. Zero falures of any kind. Actually worked on testing the accuracy of it.

Not great, but I didn't expect that. Without really working on trigger control and breath control, off a sandbag at 100 yards with surp ammo, I was getting about a 6 inch group with 20 shots. Again, I wasn't really concentrating. I was having fun.

I did not get the camo. Wish I had. Here is mine.



Top Top