Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 5/16/2003 2:52:19 PM EDT
[Last Edit: 5/16/2003 2:59:26 PM EDT by 1737]
I bought a Century arms FAL with a Hesse reciever a few years ago before I knew any better.
Sometimes it will fire a complete mag without any problems, but more often than not it wont extract the spent shell casing. It only pushes the bolt back about 1/2 inch. This will occur no matter what the setting is on gas adjustment nut.
Has anyone had a simular problem? I want to get a DSA, but I cant in good conscience sell it without it working properly.
Link Posted: 5/16/2003 3:39:08 PM EDT
Have you tried different combos of ammo and mags. If you have, then you need to take it to a FAL 'smith, maybe you have a burr or something that hanging you up.
Link Posted: 5/16/2003 3:45:51 PM EDT
[Last Edit: 5/16/2003 3:52:11 PM EDT by Gunbert]
I had exactly the same problem. Try lubing the crap out of the bolt and carrier... mine was giving me fits till I learned to not be stingy with the oil, and now she runs awesome.
Link Posted: 5/19/2003 6:19:45 PM EDT
[Last Edit: 5/19/2003 6:20:38 PM EDT by Dru]
Have you posted this question on the Fal Files? I had a simular problem on one of my fals.

I took the recoil springs out and cleaned them and the recoil spring tube. And then lightly greased the springs. Cured the problem.

Give that a try, or replace the springs all together!
Link Posted: 5/22/2003 4:00:30 PM EDT
Also, check that switch that is in front of the gas valve. If it is accidentally turned slightly to the grenade launch mode, you'll get a problem with extracting. Actually, I think that's a severe design flaw of the FAL, since simply letting the rifle rest on it's bipod can move the position of that switch.
Top Top