Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 9/3/2002 5:11:47 PM EDT
Anyone with an AR10 ever had issues with mags coming loose during fire? I've had this happen with 20rnd and 10rnd mags. These are all Armalite mags too. The mags do not fall out all the way, however they drop far enough down the mag well that the next round does not feed. Is there an adjustment that I am missing to correct this? Interestingly, this occurs about half way through either mag if this helps diagnose the issue. Thanks for the help in advance.
Link Posted: 9/3/2002 7:36:42 PM EDT
After much searching, I came across a bulletin in the AR10 board that addresses this issue. I am new to the board :)
To try an help others,try this link:
www.ar15.com/forums/topic.html?b=3&f=62&t=110491
This should end this thread.

Link Posted: 9/11/2002 6:05:10 PM EDT
Metalrock, Welcome. Sorry you have an ar10t

I have one, and now my other guns feel neglected.

Just FYI.\, you may know this, but here goes.

There is an ar-10 forum under the ar-15 part of this board, as well as an armalite forum under the industry side. The armalite forum is moderated by armalite, so you get good poop there too, but quicker response from the ar-10 part.

Don't forget to go and introduce yourself in Gen discussion.


Again, welcome

TXLEWIS
Link Posted: 9/12/2002 3:43:08 AM EDT
armalite sent me a new mag release button for this fix.......just call them...they will oblige..
Link Posted: 9/12/2002 10:37:18 AM EDT
Yep, I also have (had?) this problem with my AR10, primarily with the 10 rd mags. Armalite sent me a new mag catch. Didn't help. I ended up slightly modifying the engagement area of the cutout slot on the magazine, after talking to another AR10 owner who had mag drop issues. Seems to have cured the 10 rders from dropping. Time will tell. Doesn't exactly inspire confidence in the gun.

I like the gun, but it has been damned annoying, with a couple other glitches as well.
Link Posted: 9/12/2002 2:01:21 PM EDT
[Last Edit: 9/12/2002 2:02:42 PM EDT by metalrocks]
Hey TXLewis, thanks for the response on my inquiry and the welcome to the board. One thing in you post confused me. You said sorry that I had an AR10, but then you said you have one an all your other guns feel neglected now. Did you mean this in a good way in that your AR10 shoots well so you do not use the others or that the AR10 need so much work all the time?

Thanks for the heads up on the AR10 board, I found it the same night of the post. Since I was having a function issue, I thought it best to check armory section. However I was unaware that Armalite as a company was the moderator for AR10 board. Pretty cool. Thanks
Link Posted: 9/12/2002 2:06:26 PM EDT
Black and Green, thank you for the information. One question, did Armalite send this upon request? The reason I ask is that I called and spoke with them and was advised to ship the whole gun for the armorer to check out. The expected wait was 3-4 weeks. If they can just ship the part I'd rather do without the downtime and install this myself
Link Posted: 9/13/2002 5:14:45 AM EDT
There`s a tsb on it......i believe that it tells you to send it.....can`t exactly remember....but i`ll find it and get back to you.....if you sent in your warranty card they`ll have your serial on file and if not...you probably could tell them you are the current owner...anyway they`ll fix it.....but i will find more info....don`t send your rifle...no need...you could fix the thing yourself...like sp10 did...but i would rather go with the factory fix.......
Top Top