Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 11/5/2003 2:40:40 PM EDT
I recently purchased a used H&K/Benelli super 90. It didn't cycle when I first tried it, so I've taken it apart, cleaned and lubed it more times than I care to think about - still no luck and nothing obvious. It still will not eject a spent husk and load a new one under normal conditions. There do not appear to be any broken parts (it looks to be in great condition besides a few minor scratches on the receiver). I haven't been able to reach Benelli yet, and would appreciate any suggestions. This thing is OLD (serial under 50K). I was told it was an old PD gun, so I'm guessing it sat in a cruiser for many years.

I've used standard "wal-Mart" loads - Winchester & Remington 2 3/4" 3dram shells within the specs listed at Benelli's sight - no workie workie. It does work like a champ using slugs. It also works if I brace the stock against something solid even with the lower power ammo (ex: solidly braced against my hip). I'm leaning and bracing solidly when shooting the light loads, so I don't think it's that I'm not bracing solidly.

I'd like to thank SNIPERm88 for his help already. Anybody else with ideas would be greatly appreciated as well!

Black Fox
Link Posted: 11/5/2003 7:08:36 PM EDT
I read on another board, and I can't recall which, that the big gripe with the Benelli Super series is the aluminum receiver that gets bent when beaten severly during very active, vigorous field use.

But the specific malfunction your talking about was anecdotaly related in the same Benelli bashing thread.

Now I have to go look.
Link Posted: 11/5/2003 7:48:36 PM EDT
A couple suggestions. Thoroughly wash out the trigger assembly and the receiver with some Gun Scrubber or carb cleaner, just a as a precautionary measure. Next, check the firing pin retaining pin and see what condition the rubber O-ring on it is in. I actually had one of these start to split, and it was rubbing on the receiver making the gun sluggish.
Link Posted: 11/6/2003 2:31:14 AM EDT
Guys -

Thank you very much for the ideas!

Sherm - let me know what you find out. I've done a lot of googling' and didn't come across that. Lumpy - I'll check! Helmut - I'm consistently using 3 varieties of 1 1/8 oz loads.

I'll take a better look this afternoon and post any results.

Black Fox
Link Posted: 11/6/2003 10:00:53 AM EDT
The chamber is not by some chance pitted is it? This can and will slow down the extraction cycle enough to create a problem with lighter loads, yet the increased recoil / thrust of the heavier loads will overcome the pitting unless it is terrible bad. Heavy plastic residue can do the same thing if it has been shot a lot and not scrubbed well. Make sure the chamber is both clean and well polished as it should be.
Link Posted: 11/7/2003 7:47:45 AM EDT
Okay - I've done a little more inspection.

The trigger assembly and receiver look pristine. The receiver still has all of it's black inside (no worn silver areas). It makes me wonder how much this thing was shot. Lumpy - my firing pin retaining pin doesn't have a rubber O-ring on it?? I wasn't able to find an O-ring in the parts diagram I have either, so I wonder if this is a recent thing. The chamber looks almost new as well, ikor. I will polish it and clean it and see if that helps.

I called Benelli yesterday and described the problem. They immediately said "it's the recoil spring." Of course, this is the only part you have to send to the factory to be repaired! You can clean the recoil spring housing out by pouring oil into a small hole in the end and working the plunger with a wooden dowel or something. I had already done this, and the oil coming out looked rather rust colored. I get the distinct impression these tubes get rusted out and the spring starts getting caught in it. I'll clean it some more today and see if it helps. I've also read that there is a break-in period for the gun. They recommend you fire several boxes of 3" magnums in it to get it broken in. I may do this as well since I don't know it's background.

Thanks again for all of your help. I'll let you know how it goes!

Black Fox
Link Posted: 11/7/2003 5:18:16 PM EDT
Question...do you have a side ammo carrier on it? If you over tighten the mount screws on the ammo carrier it can crush the reicever enuff to cause jams.Did mine anyway
Link Posted: 11/10/2003 2:53:47 PM EDT
StonerStudent - I have a side saddle, but made sure it wasn't too tight. I've taken it off, and the problem persists. I guess it's time to send it back to Benelli....

Link Posted: 11/11/2003 5:06:44 AM EDT
We had multiple problems with these shotguns. The receivers do get tweaked easdily. One was put out of spec when a sidesaddle was mounted (as Stoner student mentions) and it remained so after removal.
None worked well with a sidesaddle. ZERO. ZIP.

Tactical lights are hit or miss too with them.

The recoils spring you mention is indeed the culprit. Benelli wanted us to send in several of them for their fix but we dumped them. Strange how the area which gets residue etc is not really able to be cleaned.
IMHO, any weapon that needs a replacement spring on a regular basis that is non user servicable is not fit for tactical use.
BTW- when they worked, they were awesome. All of them showed problems at a few thousand rounds mark.
Link Posted: 11/14/2003 7:36:11 AM EDT
You can replace the complete recoil spring assembly yourself but it is loctited togehter with red loctite so heat the joints before trying to unscrew them. Benelli offers a light load recoil spring assembly which could be helpful depending on your purposes. There is an after-market unit with a stainless tube which I think is called Sure-Cycle and that is intended to address the rust problem. There is no O-ring on the firing pin retainer on my gun.
I have had my Benelli for many years and fired thousands of rounds and do not have cycling problems or rust problems but I am pretty particular about cleaning, maintainance, and storage. You shouldn't need to hold the gun real tight to your shoulder and I suggest you ry a more relaxed hold. I run 3 dram x 1-1/8 oz loads min.
Link Posted: 11/14/2003 1:07:43 PM EDT
Mike_T - that's very bad news that you've had so many problems. I'm going to guess you're an armorer for a PD or something similar? I'm guessing by "we dumped them" you mean you got rid of them? Does that mean selling on the market or destroying them? I'm just curious because mine is an old PD gun. While probably not one of yours, I'm wondering if it's a result of the same approach. I agree - I'm not at all pleased to have the main spring un-serviceable. It's still a sweet shotgun, but this causes me some angst....

BillL223 - thanks for the lead on the stainless tube. If that turns out to be the problem, I'll look into it.

Just a side question - I've recently gotten involved in skeet/sporting clays. My corporate environment isn't real keen on machine guns, etc., but my execs are all about skeet shooting. It may be time to get the 26" barrel on Benelli's site for this. Anyone try this, or have any suggestions or concerns?

Thanks again.

Black Fox
Link Posted: 11/15/2003 7:18:25 AM EDT
I would suggest sending it back to Benelli (i.e., getting it working) before you order a barrel for it. Barrels are not cheep, last one I ordered retailed for $319 IIRC.

I was out shooting yesterday and we put 7 rounds of Winchester AA LIGHT TARGET in his M1, I held it out in front of me (with nothing for the gun to recoil against) and it cycled fine. His gun has less than 500 rounds through it. (AA129 2 3/4 DR. EQ. 1 1/8oz #9)

Sorry to hear you are still having problems, but that it just an example how they should function.
Top Top