Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 2/9/2006 5:54:53 PM EDT
Having an issue with my Bersa Thunder 380. I have only had it for about three weeks at the most now. And, to date, it has had maybe 70 rounds put through it. Almost all of them today. Here's the issue.

It fired well for the first 30 rounds. I was really impressed with it, honestly. But then... it just stopped. I thought it had jammed, so I cleared the round and fired again. The round fired, but the following one did not. It continued to do this for a few more rounds before I tried a different brand of ammo, but it had the same effect. Fire one, then I pull the trigger and the hammer would do nothing. Take mag out, put it back, fire, then do it all over again.

Took the grips off and someone found the spring inside had popped out of place, or we think it did anyway, because there was nothing holding the end where it was. Pushed it down, it fired off two and half magazines full before it went right back to the old issue. We took the grips off again to find the same thing, but there isn't anything there to secure the end of that spring in place. There is a place where you can fit it, but it has nothing to actually slid into or anything to hold it there.

I fired off another 18 rounds without an issue, but I ran out of ammo and the range was closing, so I didn't get to keep firing to see if it would do it again. Although I suspect it will. I plan to hit the range again tomorrow and if it does this again I will probably speak with a local gunsmith about it. But I thought I would run it past the forums here to see if anyone else has had this issue or if there is something I was overlooking during this issue. Thanks!
Top Top