Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 10/12/2003 2:40:55 AM EDT
Hello, all.

I was examining my XD the other day when it crossed my mind that perhaps the extractor wasn't supposed to appear warped near the extractor 'claw'. So far, I have had zero problems with the pistol, but one friend of mine experienced a fail to eject whereas another was subjected to a rather embarassing malfunction in which the spent casing did not fully eject from the pistol.

Should I send my XD in to Springfield for repair work? Should I simply attempt to replace the extractor myself? Does doing so require specialized tools or disassembly beyond the scope of the owner's manual? Are replacement extractors expensive?

And do you suppose it would all be worth it to have the extractor replaced and have night sights installed all at the same time?

Is it safe to continue firing my XD9? I don't go shooting regularly, as I have virtually no disposeable income, what with college and all, so if this is a problem that will develop over time, I can hold off for a near-indefinite amount of time. However, if this is a 'do not fire under any circumstances' sort of deal, I would like to know so I can plan accordingly.

Thanks in advice, all.
Link Posted: 10/12/2003 6:26:27 AM EDT
One of the things that I like about the HS/XDs is that they seem to continue working just fine even with a broken extractor. That is really comforting in a gun that might be needed for SD someday.

From your description it's very difficult to tell if yours is broken or not. But if you give Springfield a call and thell them you think yours is broken, they will send a new one out to you. It's a fairly simple swapout and you do not need any special tools. The most common cause of breakage is by hitting it with the mag lips, either from using modified mags (SiG, Beretta, S&W) or slamming the mags in place.

Another regular poster here recently found his extractor was broken while cleaning up after a trip to the range. SA shipped him another one immediately but he is continuing to shoot with the broken one just to find out how reliable the design is even when broken.
Link Posted: 10/12/2003 4:20:17 PM EDT
Ah, thanks Sig 230.

The extractor itself appears fine save for a small dent just behind the 'claw' of the part. It's fairly shallow.

Anywho, if it doesn't require complicated installation/removal, I guess I'll just call up Springfield one of these days.

Pretty cool about how it'll work with a broken extractor--I guess this isn't quite as pressing a concern as I had thought it could be.

Thanks a bunch.
Link Posted: 10/16/2003 5:17:50 PM EDT
[Last Edit: 10/24/2003 4:43:04 PM EDT by red-don]
sig_230 is mixing up the extractor and the ejector. The ejector is sometimes touched by (some) mag lips and may break. The ejector can be broken and everything will still function fine.
The extractor has the hook and is what grabs the rim of the shell. There seemed to be some problems in the first imported versions or the HS2000. Usually the XD models have a robust extractor with few problems. Still, the extractor can still be replaced by yourself if a problem does come up. Details can be found at HS2000/XD Talk
Link Posted: 10/19/2003 9:20:05 PM EDT
Thanks for the input!

One small hiccup--your link doesn't seem to work...
Link Posted: 10/20/2003 3:37:41 AM EDT
He's right. I need to get my glasses checked.
Link Posted: 10/21/2003 2:14:00 PM EDT
I bought a used XD9 very cheap because it had a broken extractor; the previous owner couldn't diagnose the problem. I called Springfield, and they sent me an RMA. Within a couple of weeks, I had the gun back with a new extractor. I haven't had any trouble with it after the repair. I didn't pay for anything, and the turnaround was extremely fast.
Link Posted: 10/21/2003 11:11:55 PM EDT
Nice. Maybe I'll try calling 'em after all.
Link Posted: 10/24/2003 4:46:17 PM EDT

Originally Posted By Brett_Bass:
Thanks for the input!

One small hiccup--your link doesn't seem to work...



'fixed my link, I had too many www and http in there.
HS2000/XD Talk
Top Top