Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Site Notices
Posted: 3/2/2006 11:51:08 PM EDT
I bought a new mid size XD 40 today. I have a subcompact XD9 that is a fantastic gun and is 100% in 2,000+ rounds. I figured this new XD40 would be as good as my 1st XD but it proved to be not so good. The gun functioned ok for the most part but had several times where the slide did not close all the way(a major failure in my book). The biggest problem was that the accuracy was HORRIBLE!!!! Form a bench rest at 10 yards the best group I could get was 5 to 6 inches!!!!!! My Sub XD9 gets 1 inch groups for that distance! I had a couple other shooters try(which are all very compitent shooters) and they did no better. I got 250 rounds through it using several diferent brands of ammo.
What could be the problem to this bad accuracy? Another shooter suggested it might be a bad barrel, I checked the crown and it looks perfect.

Thank you for any help!!!
Link Posted: 3/3/2006 1:50:58 AM EDT
Ouch man.. i want to say it allmost sounds like your recoil spring might be too light..

with the problems you discribed i would just send it back to springfield.. it sucks i know but at least they will fix your problem right..

BTW this is also comming from a MAJOR DIYer with the group size your talking about and everything else.. i would just make heavy use of that warrenty.

JMHO..

Jess
Link Posted: 3/3/2006 5:01:59 AM EDT
Wow Haven't ever herd of this one sounds like a tight chamber holding slide slightly open.

Thar group size is horrible better just send it to S.A. If you contact them get in rma and If you get the right person you should be able to get the shipping account number too
Link Posted: 3/3/2006 10:07:41 AM EDT
[Last Edit: 3/3/2006 10:10:35 AM EDT by SkagSig40]
Talk about bad luck!!!!
I just sent back my new SIG 229 back for feeding problems.....

Had to send back my Ruger Vaquero because the base pin poped out on every shot jaming the cylinder.......

Sent back my new Beretta Neos cause groups wer 12 inches low at 10 yards with the sights raised all the way........

Sent back my new S&W 686 for a cycling problem.......

Luckly all the guns were fixed right the 1st time around.

What the hell is with all this bad luck! From now on I should not even open the box whenI buy a new gun and directly ship it to the factory!!!!! It is frustrating but these are the biggest problems I have in life right now so I can't complain....life can get much worse!


I cleaned the whole gun extreemly well and cleaned the barrel 100%. I'll try it out one more time to see if that helps. If not back to Springfield it will go. Will they pay shipping both ways?
Link Posted: 3/4/2006 10:32:19 AM EDT
[Last Edit: 3/4/2006 10:32:45 AM EDT by knifehitter]

Originally Posted By SkagSig40:
Will they pay shipping both ways?



Yes, if you send/fax them the receipt they will pay shipping. Just ask the person who gives you the RMA number.
Link Posted: 3/4/2006 10:27:10 PM EDT
BTW i was reading on XDtalk about the same kind of problem.. its normally attrubited to a guide rod/ recoil spring problem..

if you dont want to send your XD back to SA.. and are willing to do a slight upgrade in hopes of fixing it you could pick up a Dons Guide Rod for the XD..

i had a simular problem today.. except my shots where right on target.. *first time i've taken my personal XD out* the gun was dry as a bone when i got it and i shot it that way.. so after a good hard cleaning tonight i am going to try it agian tomarrow see if that did the trick for me..

Jess
Link Posted: 3/4/2006 10:48:53 PM EDT

Originally Posted By Anarx:
BTW i was reading on XDtalk about the same kind of problem.. its normally attrubited to a guide rod/ recoil spring problem..

if you dont want to send your XD back to SA.. and are willing to do a slight upgrade in hopes of fixing it you could pick up a Dons Guide Rod for the XD..

i had a simular problem today.. except my shots where right on target.. *first time i've taken my personal XD out* the gun was dry as a bone when i got it and i shot it that way.. so after a good hard cleaning tonight i am going to try it agian tomarrow see if that did the trick for me..

Jess



I must be miss understanding you. If your gun shoots right on then what is the problem? Thanks.
Link Posted: 3/9/2006 11:05:49 PM EDT
UPDATE:
Range trip # 2. Today I fired another 100 rounds and had the same problem of 3 to 6 inch groups at 10 yards from a bench rest and the dam slide fails to go into battery almost once per mag. The gun was 100% cleaned and oil so that was not the problem. I got consistant 1 inch groups with my XD9 sub compact today too so I know it is not me. I'm calling Springfield in the morning.
Top Top