Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Arrow Left Previous Page
Page / 2
Posted: 1/5/2006 12:30:55 PM EDT
[Last Edit: 3/5/2006 3:16:10 PM EDT by hobbs5624]
2 internal and one external running just fine.
Link Posted: 1/5/2006 1:47:52 PM EDT
4 internal 100% reliable
Link Posted: 1/5/2006 2:18:43 PM EDT
Link Posted: 1/5/2006 2:47:55 PM EDT
2 external, and both 100% so far.
Link Posted: 1/5/2006 3:21:42 PM EDT
-2, internals. Both were problems out of the box. Bought both used, as new.

Compact SS I corrected with good mags and later a Wilson BP extractor. Good pistol. Usually my CCW.

Custom LE was a jammamatic when it got dirty. I mean less than 50 rounds dirty. It hated cast reloads than my 1991Colt loved. Good mags and new extractor no fix.
Link Posted: 1/5/2006 10:21:21 PM EDT
+2 internal

one with 15,000+ rounds with no non-ammo related failures
Link Posted: 1/5/2006 10:33:07 PM EDT
1 internal, 100% so far with 650 rnds fired.
Link Posted: 1/5/2006 11:09:32 PM EDT
[Last Edit: 1/5/2006 11:10:29 PM EDT by mgw24]
Early TLE II. Only one FTF ever, first mag. Over 2k rounds through pistol. The last 1k without cleaning/lube.

+1 Internal
Link Posted: 1/6/2006 12:14:16 AM EDT
[Last Edit: 1/6/2006 12:15:24 AM EDT by NRose8989]
i have a TLE II w/internal. i bought it brand new straight from the factory and the first mag had 2 FTF but hostestly after that mag i put 600 rounds through it with no problem so im going to say 100% reliable. im guessing the parts just needed to wear in a bit. +1 internal
Link Posted: 1/6/2006 3:10:20 AM EDT
Stainless TLE II w/EE Never had any problems.
This was traded in for:
Stainless Pro TLE/RL II w/IE Haven't had any problems so far.
Link Posted: 1/6/2006 5:23:36 AM EDT
1 IE - no probs.
Link Posted: 1/6/2006 8:28:46 AM EDT
[Last Edit: 1/6/2006 8:30:28 AM EDT by Joe_Blacke]
+5 Internal. All Series 1 in either the Classic Custom or Royal Custom config. 5" models.

All have run 100% (non ammo related) for as long as I have had them. The ONLY failure's I've ever had was on a batch of handloads where I did not set the crimp properly. The lack of crimp was causing the bullets to set back in the case during cycling, causing a failure to return to battery. I've used Wilson mags, Kimber OEM mags, and Chip McCormick mags. All have worked 100%.

As an aside, I did a year long test with one of my pistols to see what type of abuse (actually neglect)it would require to cause a malf. I shot this gun a minimum of 500 rounds a month, and never cleaned it. I stored it in a leather holster the entire time, and the gun pretty much lived in my truck. It was filthy, dusty, and the at times the slide felt very gummy when the action was cycled. Still, it never malfunctioned once. When I eventually did clean the gun, the only problem I found was some light rust in the bore. A good cleaning, plus a trip to the range took care of that problem.
Link Posted: 1/6/2006 2:00:44 PM EDT
+ 1 External 100%
Link Posted: 1/6/2006 5:13:55 PM EDT
+1 external TLE
+5 internal both 4" and 5" guns with my Clackamas having over 7000 rounds w/o a malfunction that wasnt mag or ammo related
Link Posted: 1/6/2006 6:08:55 PM EDT
[Last Edit: 4/17/2006 12:42:55 PM EDT by Marksman14]
Edited cause I was wrong.

Not happy.
Link Posted: 1/6/2006 6:10:24 PM EDT
-1 For each. Probably one malfunction in 100 rounds with the external. Half that with internal.
Link Posted: 1/6/2006 8:38:16 PM EDT
+1 for internal. Over 5000 rounds, not a hitch.
Link Posted: 1/7/2006 10:16:13 AM EDT
[Last Edit: 1/7/2006 10:18:59 AM EDT by shark77]
TLE with EE - no extractor problems in over two years of shooting on a regular basis

CDP II with IE - no extractor problems in one year of shooting on a regular basis
Link Posted: 1/7/2006 3:32:31 PM EDT
4 EE - All unreliable.

No problems with friends Kimbers with IE's, Springers, and Colts.

Link Posted: 1/7/2006 3:46:02 PM EDT
[Last Edit: 3/14/2006 6:53:16 PM EDT by stingerHP]
+1 External
+2 Internal

No problems with any!

Link Posted: 1/8/2006 11:59:44 AM EDT
Link Posted: 1/8/2006 12:26:01 PM EDT
[Last Edit: 1/8/2006 7:45:44 PM EDT by hobbs5624]
.
Link Posted: 1/9/2006 9:06:21 AM EDT

Originally Posted By hobbs5624:
.



Link Posted: 1/9/2006 11:46:42 AM EDT
+1 IE

Bought used, I've put about 8500 rds through it, zero extractor problems. It will jam after about 100 rounds of LSW reloads and I had two magazine related failures. I put 800 rounds of ball and various hollow points without cleaning and it ran fine.
Link Posted: 1/9/2006 3:44:40 PM EDT
+1 EE Pro Raptor II w/no problems. About 1,000 rounds FMJ through it.
Link Posted: 1/9/2006 4:51:39 PM EDT
Link Posted: 1/9/2006 10:17:23 PM EDT
[Last Edit: 3/3/2006 11:05:46 PM EDT by BSheppard]
After a trip to Kimber for some polishing of this and that my Warrior is 100% even with HP. It is a Internal Extractor.
Link Posted: 1/10/2006 3:59:17 PM EDT
+1 EE 100% 750-rounds through
Link Posted: 1/11/2006 5:22:12 PM EDT
+1 internal custom target with 1000's of rounds.
Link Posted: 1/15/2006 8:23:49 AM EDT
1 external- problems every other mag. FTF and FTE. Jam-O-Matic . Sold.....
Link Posted: 1/16/2006 6:34:06 PM EDT
[Last Edit: 1/16/2006 6:34:46 PM EDT by MaverickMkii]
2 x Series II with internal extractors; both 100% including JHP's (bought the first one used)

*Currently only using factory Kimber mag and CMC regular mags which are considered crap by most people
Link Posted: 1/18/2006 3:03:26 PM EDT
Just bought a Pro TLE/RL with the external extractor. Less than 200 rounds and already more than 20 FTE failures!

What can I do to correct this? Please IM me with info. Thanks,

Andrew
Link Posted: 1/21/2006 6:22:44 PM EDT

Originally Posted By AndyTut22:
Just bought a Pro TLE/RL with the external extractor. Less than 200 rounds and already more than 20 FTE failures!

What can I do to correct this? Please IM me with info. Thanks,

Andrew


Call Kimber and get a RMA. Send it in and with any luck they will replace it with a new slide with an internal extractor.
Link Posted: 1/21/2006 8:49:00 PM EDT
I have 1000 rounds through my TLE with EE, no problems, no FTF, no FTE. I'm pretty happy.
Link Posted: 1/22/2006 3:16:07 AM EDT
Link Posted: 1/26/2006 5:45:04 PM EDT
1 External. No problems
Link Posted: 1/26/2006 7:07:05 PM EDT
1 Stainless Custom II: Never had a single problem in ~1000 rounds
Link Posted: 1/28/2006 9:23:57 AM EDT
All of my Series 1 Kimbers have been 100% reliable.
I don't do Series 2.
Link Posted: 1/28/2006 2:17:30 PM EDT
External TLEII/RL
Started feeding and ejecting reliably around 100 rounds. Wilson Mags are a must.
Link Posted: 2/4/2006 8:07:04 PM EDT
I own 1 Kimber Custom II with the EE. I put about 1200 rounds down range and not a single problem. The one I thing I did was to trash the factory mag, rough feed lips, before using it. I only use MecGar chromed mags, best mag there is in my opinion.
Link Posted: 2/5/2006 11:47:03 AM EDT
1+ IE 100% reliable
1+ EE Not reliable FTEs Is on second trip to factory.
Link Posted: 2/5/2006 1:35:27 PM EDT
Other than a person who did not specify extractor type on his Series II and the guy who did not specify how many Series I guns he had, here are the results so far:

-Internal: 38 reliable, 3 unreliable
-External: 15 reliable, 12 unreliable

Of the guns listed so far, that means internal extractors are 92.68% reliable, and that external extractor guns are 55.56% reliable. Total percentage of Kimbers regardless of extractor type that are listed as reliable is 77.94%. I realize this is not very scientific, with only 34 people's info, but it gives a rough idea.
Link Posted: 2/6/2006 1:47:46 PM EDT
Still having serious trouble with my Pro TLE/RL II with External Extractor after more than 500 rounds through it. I just packed it up to ship back to Kimber. Hopefully they get it right the first time!!! (Well, the second time, actually!) Wish me luck! Thanks,

Andrew
Link Posted: 2/6/2006 2:39:07 PM EDT
Experience with two EE pistols, both were reliable for several thousand rounds then the extractor took a dump.
Link Posted: 2/6/2006 3:23:21 PM EDT

Originally Posted By Combat_Jack:
Experience with two EE pistols, both were reliable for several thousand rounds then the extractor took a dump.



To be fair, I feel the extractor is the weak link on IE guns as well-at least until you install a properly contructed and tensioned part. I've replaced the extractor on my loaded Springfield about 18 months ago. The factory part didn't like type 3 malf drills, and had been virtually 100% until a handful of FTFs on the same day after the drills. The gun has had exactly ZERO jams since I replaced the part with at least 3-4K downrange.

My 1991A1 Colt, purchased NIB sometime around 1992-3 is still on its original part. This was my main shooter until my recent Springfields and another outstandingly reliable pistol.

I'd hope the problem rate isn't > 40% overall for the EE guns, but that could explain why it is going the way of the dodobird.
Link Posted: 2/8/2006 4:07:32 PM EDT
I have a Warrior with about 5000 rounds fired. I had 3 FTE in the first 500 rounds. Truth be known the FTE's were probably due to weak grip or wrist. The gun is very reliable. This is my favorite ccw.
Link Posted: 2/14/2006 1:36:58 PM EDT
Internal Ultra Raptor. first 200 rounds I had 6 FTF's now it is 100% at about 2k rounds
Link Posted: 2/15/2006 5:56:20 AM EDT
Bought a used TLE/RLII w/ external extractor, not sure how many rounds were through it before I bought it but it's definitely used. Has been reliable for me so far (few hundred rounds)

+1 for my EE.

Link Posted: 2/15/2006 4:45:43 PM EDT
[Last Edit: 2/15/2006 4:46:17 PM EDT by MillerSHO]

Originally Posted By mlm1219:

Originally Posted By AndyTut22:
Just bought a Pro TLE/RL with the external extractor. Less than 200 rounds and already more than 20 FTE failures!

What can I do to correct this? Please IM me with info. Thanks,

Andrew


Call Kimber and get a RMA. Send it in and with any luck they will replace it with a new slide with an internal extractor.



If you have my luck, even when the replaced the slide to an internal extractor, you'll still have issues.

For the record my TLE/RLII Pro has been through the following and I just had to send it back AGAIN.
3 barrel, 3 guiderods, 3 slides, 2 frames, still not working.

This has been ongoing for almost a year now.
Link Posted: 2/16/2006 3:39:40 AM EDT
+5 Internal
+1 External
All of my Kimbers have been flawless.
Link Posted: 2/16/2006 7:20:25 AM EDT

Originally Posted By MillerSHO:

Originally Posted By mlm1219:

Originally Posted By AndyTut22:
Just bought a Pro TLE/RL with the external extractor. Less than 200 rounds and already more than 20 FTE failures!

What can I do to correct this? Please IM me with info. Thanks,

Andrew


Call Kimber and get a RMA. Send it in and with any luck they will replace it with a new slide with an internal extractor.



If you have my luck, even when the replaced the slide to an internal extractor, you'll still have issues.

For the record my TLE/RLII Pro has been through the following and I just had to send it back AGAIN.
3 barrel, 3 guiderods, 3 slides, 2 frames, still not working.

This has been ongoing for almost a year now.



Betcha I could fix it.... Seriously, if it does not work this next time, tell Kimber that you want them to send it to a 1911 smith of your choice on their dime, or just tell them they can send you a whole new gun. That is just ridiculous to have the gun not corrected after all those trips.
Arrow Left Previous Page
Page / 2
Top Top