Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 4/3/2006 9:14:50 PM EDT
I have a question

I just bought a P229. I went to the range with it on Sat and put 100 rounds through it. I noticed that when the clip is empty the slide does not lock open as it does with other Semi autos I have fired. Is this a Normal for a P229?

Thanks

Pat
Link Posted: 4/4/2006 1:07:26 PM EDT
Check your grip. I don't know about your experience with Sigs, but a lot of people have trouble with their thumb resting on the slide catch. If that's not it, maybe you should look at your mags and make sure they're clean and lubed. Hope that helps.
Link Posted: 4/4/2006 11:21:36 PM EDT
Something’s wrong. (Presumably you’re not using an aftermarket magazine!)

Try this:

Seat an empty mag in your pistol and see if the slide will lock back (like it should).

If it will, the possibilities are:

You’re holding down the slidestop when shooting as described by pointfive0 above.

You haven’t cleaned and oiled the thing before shooting it. (Note that SIG’s run best when they’re well-oiled. The magazine also needs to be cleaned inside and out, though it should only be very lightly oiled if at all.)

You’ve got the recoil spring backwards on the recoil spring guide. The tight end of the spring should go on the guide first.

You’re using weak ammo that won’t push the slide back far enough to lock.

Alternatively, you might be limp wristing it a bit and causing the same problem.

OTOH, if seating an empty magazine and pulling the slide back won’t put the pistol in slide-lock, the possibilities are:

You’ve got the mag spring backwards in the magazine.

While not likely, it’s also possible that magazine follower, the slide lock, or the slide lock notch in the slide is defective. Or maybe the magazine spring is really weak.
Link Posted: 4/6/2006 10:21:58 PM EDT
Thanks for the quick answers!!

My buddie was with me said i was limp wristinig it, so next time I hope to correct that problem.

I did not oil the Clips before I shot them. I was using Factory clips

Thanks again

Pat
Link Posted: 4/6/2006 10:27:23 PM EDT

Originally Posted By tunnelpat:
I have a question

I just bought a P229. I went to the range with it on Sat and put 100 rounds through it. I noticed that when the clip mag is empty the slide does not lock open as it does with other Semi autos I have fired. Is this a Normal for a P229?

Thanks

Pat


use the correct terminology or you'll get flamed
Link Posted: 4/6/2006 11:15:26 PM EDT
what did i do wroing? so i can learn from it?
Link Posted: 4/6/2006 11:22:40 PM EDT

Originally Posted By tunnelpat:
what did i do wroing? so i can learn from it?


don't call magazines clips
clips are used in garands but pistols and AR15's use magazines.
Link Posted: 4/6/2006 11:31:47 PM EDT
ok thanks!!

Link Posted: 4/7/2006 4:46:14 AM EDT
[Last Edit: 4/7/2006 5:37:56 AM EDT by CopM4]
Also stay away from "oiling" your mag. Just a casual swipe with your finger with very little.
Better yet get some sort of dry lube and use it sparingly.

An oil soaked mag or pistol only attracts crud
Top Top