Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Page AK-47 » SKS
Posted: 2/20/2006 10:28:07 AM EDT
[Last Edit: 2/20/2006 10:37:52 AM EDT by grizzy2005]
Recently bought an unissued yugo SKS at a gun show, got it home and cleaned all the cosmo out and lubed it. I took it shooting about a week later. The first few shots were fine, then it started failing to eject the spent casings all the way. It would back them about half way out of the chamber and they would go right back in - not stripping a new round from the mag.

I took it home and cleaned it again, making sure it was 100% lubed. Took it out soon after and it was doing the same thing AND once in a while it would get a casing stuck in the chamber (only spent casings) so I decided to do a bit of troubleshooting.

I cycled 30 or 40 unfired rounds through with no problems, and then tried to cycle a few spent casings (picked up after shooting, cleaned before I tested them). The very first one got stuck and required a bit of beating on the charging handle to pull it loose. The second spent casing also got stuck, only I can't get it out at all. I pulled the extractor back with a screwdriver and pulled the bolt assembly and locked it back.

I tried tapping the round out with a cleaning rod down the barrel, spraying down the barrel with penetrating lube, nothing will get this round unstuck. After letting the penetrating oil soak in for almost 30 minutes, I let the bolt assembly forward to try to pull it out with the extractor. After hitting it with a hammer a few times, the extractor actually broke a chunk out of the lip of the casing!

I'm guessing the lacquer from the wolf ammo melted a bit and got it stuck in the chamber, but I am hesitant to take a torch to it to see if I can melt it loose.

Has this happened to anyone before, and is there another way to get the casing out? I'm tired of fighting it, and I really don't want to have to take it to a gunsmith and have to pay to get it removed. Any ideas?
Link Posted: 2/20/2006 10:46:28 AM EDT
[Last Edit: 2/20/2006 10:47:01 AM EDT by MikeHunter]
strip everything off of it then put the flat part of the receiver on the floor put a wooden dowel down the barrel that has a smooth but not loose fit then take a hammer and hit it as hard as you can. also i have never heard of this happening. and it sounds like you have a weak buffer spring and it isnt doing a complete cycle.
Link Posted: 2/20/2006 11:17:51 AM EDT
Alright, I'll try that tom.

Do you think heating the chamber with a torch will help at all? Or is that a bad idea? I've never had this happen before and for some reason I have a feeling that heat will help break it loose.
Link Posted: 2/21/2006 6:20:24 AM EDT
heat would make it swell
Link Posted: 2/22/2006 6:45:25 AM EDT
If I had to guess, I'd say you might have some cosmoline still up in the chamber area. It's a LOT more likely than Wolf ammo coating gumming things up.
Link Posted: 2/22/2006 7:38:21 PM EDT
Well the dowel rod got it out. It was pretty gunked up between a little bit of cosmo I missed and some powder residue. Cleaned it out and cycled a few spare spent casings and they cycled fine. I'll be heading to the range in the morning and make sure everything is alright.
Link Posted: 2/23/2006 2:51:22 AM EDT
if it still isnt ejecting them then the recoil spring is probably weak
Link Posted: 2/23/2006 9:25:52 AM EDT

Originally Posted By MikeHunter:
if it still isnt ejecting them then the recoil spring is probably weak



That's not the problem, I've tried using my brother's bolt assembly w/ spring along with my friend's and it still would do the same thing. I guess the chamber was just really dirty. I didn't get out shooting today, but i'll have time tuesday or wednesday.
Link Posted: 2/25/2006 9:04:55 PM EDT
Do you have the gas valve open?
Link Posted: 2/26/2006 12:02:11 PM EDT
this happend to me last month when i got my first sks. i just gave up and exchanged it for a new one today from the guy i bought the first one from. hope this one works better.
Link Posted: 2/27/2006 11:16:38 AM EDT
Yep, it seemed to work fine when the gas valve was closed, I just had to cycle it manually. It rarely got stuck that way. With the valve open, it would pull the casing about halfway out (not a full cycle) and slam it back in and get stuck.
Link Posted: 3/4/2006 2:01:27 PM EDT
Well took it out today after a REALLY good cleaning and lubing, and it functioned flawlessly. I guess I just didn't get all the cosmo out the first time.
Page AK-47 » SKS
Top Top