Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login
Posted: 2/26/2006 9:53:03 AM EDT
Looks like my hammer is holding it up. I can send it forward with a sharp hit. OTherwise, a manual bolt retraction leaves it held open, and when I'm firing from 20 round mags stoppages occur every 5 or so rounds with round being half in chamber, half in mag, and bolt denting the side. HAve to take out mag to clear this. VERRRRRY annoying from a gun I expected to be dependable. Gun is brand new with G2 trigger. Sorry for the lack of post structure, really pissed.
Link Posted: 2/26/2006 10:33:51 AM EDT
does the bolt go too far back?

try a recoil buffer if it does.
Link Posted: 2/26/2006 12:27:39 PM EDT
Take your hammer out of the problem rifle and one that is cycling fine and contour the problem hammer just like the good one. I had to do that to one of mine to get it working right. However, try the buffer first. This seems to be a common problem on rifles built up with GT recievers.
Link Posted: 2/26/2006 1:39:56 PM EDT
This just occured to me on my most recent '74 build... you won't believe the solution.

Do you have a Bolt Buffer in the rifle? Here's why....

MY bolt was hanging up when pulled fully to the rear. I checked the Hammer (a nice GT) - no issues. Scratched my head & really LOOKED at the operation with the cover off....

The damn bolt carrier "tail" was entering the Bolt Buffer indent a wee bit low. That stinking BUFFER was holding the carrier back. I dremmeled the Bolt buffer "indent" a bit... no more hang up.
Link Posted: 2/26/2006 10:34:33 PM EDT
Just finished my m92 build on a gt receiver and it does the same thing. No buffer. Any ideas?????????
Link Posted: 2/26/2006 10:37:28 PM EDT
Just finished my m92 build on a gt receiver and it does the same thing. No buffer. Any ideas?????????
Link Posted: 2/26/2006 10:49:44 PM EDT
[Last Edit: 2/26/2006 11:19:53 PM EDT by clange]
Maybe the trigger axis hole is too high, or the hammer is too 'thick'. Either could cause the carrier hammer interference problem, but most of the time its normal for it to catch a bit. All my AKs do it to some extent.

You could try taking some material off the hammer, or have the builder work on it if theres a warranty. Most of the time the carrier catching on the hammer a is normal. If you let the bolt go from all the way back it should clear it and strip a round. If theres interference to the point even if you let it slam forward and it catches, something is deffinately wrong.

The jamming sounds like it could possibly be unrelated. There could be problems with the mag catch seating the mags too low or something. See if it still jams when you pull the mag back slightly, or if the problem is just with 20 rounders, its possible the tabs are slightly different on those.

FWIW my 74 is built on a global 1.0mm with a g2 double hook, made early last year, and it doesnt have this problem. Maybe theres a recent problem with the globals, or the G2s if this is common.
Top Top